Bug 190906 - Yumex crashes with exception at startup
Yumex crashes with exception at startup
Status: CLOSED DUPLICATE of bug 190653
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-06 05:48 EDT by Nick Thompson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-08 02:54:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Thompson 2006-05-06 05:48:58 EDT
Description of problem:

Yumex crashes on startup.


Version-Release number of selected component (if applicable):

1.0.0


How reproducible:

Run yumex - failure follows some time later before yumex is ready to use


Steps to Reproduce:
1. run yumex
2. wait a few seconds :-)
3.
  
Actual results:

Exception flaged. Text follows:

Component: yumex
Version: 1.0.0
Summary: TB2eba5ffb updates.py:521:getObsoletesList:AttributeError: Updates 
instance has no attribute 'obsoletes'

Traceback (most recent call last):
  File "yumexmain.py", line 948, in ?
    mainApp = YumexMainApplication()
  File "yumexmain.py", line 477, in __init__
    self.setup_yum()
  File "yumexmain.py", line 899, in setup_yum
    self.yumexbase.build_package_lists( self.recentlimit, pkglists )
  File "yumexBase.py", line 499, in build_package_lists
  File "updates.py", line 521, in getObsoletesList
AttributeError: Updates instance has no attribute 'obsoletes'

Local variables in innermost frame:
newest: 0
self: <rpmUtils.updates.Updates instance at 0xb794e4ac>
arch: None
name: None


Expected results:

No exception was expected.


Additional info:

none
Comment 1 Tim Lauridsen 2006-05-08 02:54:16 EDT

*** This bug has been marked as a duplicate of 190653 ***

Note You need to log in before you can comment on or make changes to this bug.