Bug 19094 - Installation with boot.img failed while reading package informations
Installation with boot.img failed while reading package informations
Status: CLOSED DUPLICATE of bug 18019
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 35875 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-13 22:08 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-09 16:28:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-13 22:08:25 EDT
Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", line 33, in __call__
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", 
line 43, in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in __init__
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 353, in readCompsFile
  File "/tmp/lib/python1.5/urllib.py", line 59, in urlopen
    
return _urlopener.open(url)
  File "/tmp/lib/python1.5/urllib.py", line 159, in open
    return getattr(self, name)(url)
  File 
"/tmp/lib/python1.5/urllib.py", line 330, in open_file
    return self.open_local_file(url)
  File "/tmp/lib/python1.5/urllib.py", line 340, in 
open_local_file
    return addinfourl(open(url2pathname(file), 'rb'),
IOError: [Errno 2] No such file or directory: 
'/tmp/hdimage///RedHat/base/comps'

Local variables in innermost frame:
mtype: None
self: <urllib.FancyURLopener instance at 
835fa40>
mimetypes: <module 'mimetypes' from '/tmp/lib/python1.5/mimetypes.pyc'>
StringIO: <module 'StringIO' from 
'/tmp/lib/python1.5/StringIO.pyc'>
file: /tmp/hdimage///RedHat/base/comps
url: /tmp/hdimage///RedHat/base/comps
host: None
headers: 
Content-Type: text/plain

mimetools: <module 'mimetools' from '/tmp/lib/python1.5/mimetools.pyc'>

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'ext2'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>

I would appreciate if you would tell me how I can install RH 7.0 asap. For me using the boot.img is the only possibility because I am sitting 
behind a firewall that does not allow me to connect to a ftp Server in order to install by bootnet.img. Neither I have a CD writer. Please tell me 
soon, because I really need to install my Linux to be able to work on my studies.

Yours sincerely,

S. Burmeister
Comment 1 Brock Organ 2000-10-17 19:11:31 EDT
hmmmm ... can you verify your download of the Red Hat Install sources ...? Often
missing files (such as 'comps' in your example) above occur with a bad/corrupt
download ...

hope this helps ... :)
Comment 2 Need Real Name 2000-10-18 12:13:12 EDT
Because of being unfamiliar with SunOs and ftp, it could have been, that I downloaded only *.* and not *. I have downloaded everything once again. 
/RPMS and /base. But the installation failed again. I will post the bug at the end of this comment. Do I need the /instimage directory?

If it does not work at all, is it possible to use the bootnet.img and anter a username and password for the proxy-server? My problem is that I am sitting 
behind a firewall hence I can not download RedHat directly but have to log in with my username and password. As far as I am concerned the bootnet.img 
does not give the possibility to log in before trying to contact the ftp.server. Or do http.server exist, where I can get RedHat from?

Thanks a lot for your effort,

Sven

The bugreport:

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", line 33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in __init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in __getitem__
KeyError: basesystem

Local variables in innermost frame:
self: <comps.HeaderList instance at 82b4dc0>
item: basesystem

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>
Comment 3 Michael Fulbright 2000-11-09 16:28:04 EST
There is something wrong in the hard drive install image that you downloaded. Be
sure you get all the required files and have downloaded them in a binary safe
fashion.

*** This bug has been marked as a duplicate of 18019 ***
Comment 4 Brent Fox 2001-04-13 12:55:27 EDT
*** Bug 35875 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.