Bug 19097 - Graphical installer/XFree86 does not work with Trident 3DBlade 9880 video card
Graphical installer/XFree86 does not work with Trident 3DBlade 9880 video card
Status: CLOSED DUPLICATE of bug 18773
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-13 22:33 EDT by Scheidecker
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-08 21:39:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scheidecker 2000-10-13 22:33:50 EDT
Red Hat 6.2 did not work with trident 3DBlade 9880 as I have tried both 
PCI and AGP versions. This time with Red Hat 7.0 I had the same problem 
execpt that the graphical installation locks the system. I have tried the 
same on three different Pentium (Processor/Motherboard) systems and all 
had the same problem. The Trident 3DImage 9750 has a problem on Red Hat 
7.0 but used to work just fine on Red Hat 6.2 as described on Bug # 18773.
I hope Red Hat folks figure this out soon because most of my company 
systems have Trident boards. I have been purchasing other boards to 
resolve the systems that must have Red Hat 7.0 but this is getting very 
expensive.I would appreciate any help!
Thank you,
Carlos Fernando Scheidecker Antunes.
Comment 1 Alan Cox 2000-10-14 17:49:48 EDT
If you do a text install and then configure X11 does it behave or lock ?
Comment 2 Scheidecker 2000-10-14 21:26:32 EDT
It locks, the problem is that X locks. I've tried that also already.
Comment 3 martin 2001-01-02 10:32:19 EST
Same with Cyber 9397/DVD - any attempt to use XFree86 with the trident driver
freezes up the system - except ONCE - when I actually managed to get X going. I
have no idea what it is I did but everything worked so well and so fast that now
I am pining for what ever I did to get it working that time. But the graphical
install froxe the machine and most attempts to run X 4.01 after a text install
also freeze the system.

Interestingly also Xconfigurator crashes with a segmentation fault when I click
OK after it has probed my card (and found the correct settings) or, in expert
mode, when I chose ANY card from the list. GDB tells me this is in strcpy.
Comment 4 martin 2001-01-02 18:06:03 EST
Me with the Cyber 9397 DVD again. More investigation revealed some very
interesting results. Firstly using 

	Option "noaccel" "on" 

in the XF86Config device section made it all work. So does 

	Option "nommio" "on" 

without the the noaccel option. (And, yes, its takes a bit of digging to realize
that these options even EXIST - GREAT DOC!!!!!)

But probably the most interesting is the fact that I figured out what I did to
get full acceleration working without locking the screen. Basically do this:

	1) Configure a XF86_SVGA config with the 

		Option "accel"

	 in the device section.

	2) Run:

		XF86_SVGA -xf86config <your config file name>
	
	3) Hit <CTRL><ALT><Backspace> to quit the X server

Now that won't do alot - the accel option on the 3.3.6 XF86_SVGA driver for my
card makes a complete hash of the screen. BUT after having done that, and before
rebooting, try starting the XFree86 server with the trident config without any
of the acceleration switch-offs. IT WORKS!! It least it does on mine!

Conclusion - the XF86_SVGA server, though good for nothing in accelerated mode
as a server in its own right, does some initialization of the Cyber card that
the 4.0 trident module does not do. Once properly initialized by XF86_SVGA,
XFree86/trident works with full acceleration - and it seems pretty darn fast
too!

So, RH - do you have enough to find this one now.

PS when the screen locks no X log file is saved - so its not possible to see
what the initialization differences are between the locking startup and the
non-locking startup.
Comment 5 Scheidecker 2001-01-08 21:39:09 EST
Hello all!

It is 00:29 and after almost 3 monthes, I finally managed to run X with Trident 
3DBlade 9880!

It is easy :

First, install your Red Hat 7.0 text mode.

Then, download the driver at Trident's at 
http://www.tridentmicro.com/videcomm/download/blade_9880.htm and select Linux 
Alpha Display Driver. Yes, that's it the Alpha Display Driver! My machines are 
intel Pentiums, by the way.

Yeah, my machine is an i386 but I've downloaded this driver.

use the address 
http://www.tridentmicro.com/videcomm/drivers/blade_3d/xf86_svga.gz 

Download it to /root then unzip it with the command gunzip xf86_svga.

Then, replace the XF86_SVGA located at /usr/bin/X11R6 with the new one. Just 
copy : cp /root/xf86_svga /usr/bin/X11R6/XF86_SVGA. This driver is smaller than 
tje original.

To finish, run setup and you've got it!

I was able to run it with all my i386 qith Trident 3DBlade with the highest 
video configuration my monitors support!

regards,

Carlos Fernando Scheidecker Antunes.
Comment 6 Karsten Hopp 2001-02-15 11:38:03 EST

*** This bug has been marked as a duplicate of 18773 ***

Note You need to log in before you can comment on or make changes to this bug.