Bug 18773 - Graphical installer/XFree86 does not work with Trident 3DImage 975 (AGP) video card
Graphical installer/XFree86 does not work with Trident 3DImage 975 (AGP) vide...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
: 18865 19097 19241 20282 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-10 01:59 EDT by tony.ransom
Modified: 2007-04-18 12:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 11:58:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tony.ransom 2000-10-10 01:59:40 EDT
The graphical installer does not work with the above mentioned video card. The text installation worked, but
I have not been able to configure x-windows using Xconfigurator. It correctly detects the card, but will
not configure properly. The picture is almost monochrome in appearance.
Comment 1 Scheidecker 2000-10-13 22:26:34 EDT
Yes, I did experienced the same problems. I have tried a Linux update over an 
existing 6.2 system with a Trident 3DImage 975 PCI Jaton 4mb and now the startx 
works but the video has problems with the white colors. It is the same when you 
use the graphical installation : the first sreen with the Red Hat Logo only 
shows all the colors but whites. Meaning the screen is mostly black with the 
red color of the Red hat logo. Another card the has problems is the trident 
3DBlade 9880 8mb Jaton. With this video card the graphical install locks the 
system. I have tried both PCI and AGP versions of the 9880 and the result is 
the same : system locked.
Comment 2 tony.ransom 2000-10-16 20:42:34 EDT
Since posting this bug report I have been able to configure the trident card by using Xconfigurator in expert mode  (Xconfigurator
does not pick the card to be in an AGP slot) and the switch that specifies the use of Xfree 4.0.1 drivers. The problem seems 
to be with the Xfree 3.3.6 SVGA driver. I experimented with the 3.3.6 in RH 6.2, and it worked better, but not perfectly. 

Needs work!

Comment 3 Michael Fulbright 2000-10-18 16:37:19 EDT
*** Bug 18865 has been marked as a duplicate of this bug. ***
Comment 4 Michael Fulbright 2000-10-27 15:51:17 EDT
Could you attach the output from the lspci command?
Comment 5 Dean Samuels 2000-11-03 00:05:09 EST
The problem installation screen has also been encountered by the Asia-Pacific
office at one of our training facilities which uses Trident 3DImage 975 (PCI)
cards.  What is the fix/upgrade remembering this is the PCI version of the
Trident 3DImage 975 video card.  The xfree86.org documentation states that this
card (generic) is supported in both XFree86 version 3.3.6 and 4.0.1. 
Additionally, this card works fine in RH6.2.
Comment 6 Dean Samuels 2000-11-03 00:05:17 EST
The problem installation screen has also been encountered by the Asia-Pacific
office at one of our training facilities which uses Trident 3DImage 975 (PCI)
cards.  What is the fix/upgrade remembering this is the PCI version of the
Trident 3DImage 975 video card.  The xfree86.org documentation states that this
card (generic) is supported in both XFree86 version 3.3.6 and 4.0.1. 
Additionally, this card works fine in RH6.2.
Comment 7 Michael Fulbright 2000-11-28 12:29:55 EST
Assigning to Xconfigurator maintainer.
Comment 8 Steven M. Ward 2001-01-19 19:18:27 EST
I encountered the same problem after upgrading from 6.2 to 7.0.  I also tried
installing
a Trident 3DImage985 (only comes in AGP version) and it behaved the same way.
Both the 3DImage975(AGP) and the 3DImage985 worked fine under 6.2.
--sward@cfa.harvard.edu    Steven Ward
Comment 9 Robert 2001-01-27 20:33:10 EST
Hey Y'all, 

	This may help if your installation is driving you insane due to a Trident
3DImage 975 card.
This is how I set it up using the RHL 7.0 distribution.

1) Do the setup in text mode

2) Have the machine boot into text mode. I actually did the rest of this after
booting into graphics mode; but, it is a nightmare. Save yourself the trouble.

3) Log in as root and:
 a) Xconfigurator --expert --preferxf4

4) Set up your server as you wish. I used the following:
 a) Chhose a card:
	Trident 3Dimage 975 (generic)
 b) Monitor setup:
	Princeton Ultra 75e
 c) Video memory:
	4 meg
 d) Clockchip configuration:
	No clockchip setting (reccomended)
 e) Select video mode:
	8 bit:
	1152x864
	1280x1024
	16 bit:
	800x600
	1024x768
	24 bit:
	640x480

5) Run the test and you should be good to go. Remember to have the system boot
into graphics mode now. 

The above settings were correct to my machine's specs. as far as I know. I do
hope this helps!
Comment 10 Karsten Hopp 2001-02-15 11:37:58 EST
*** Bug 19097 has been marked as a duplicate of this bug. ***
Comment 11 Mike A. Harris 2001-04-02 13:15:14 EDT
*** Bug 20282 has been marked as a duplicate of this bug. ***
Comment 12 Mike A. Harris 2001-04-02 13:20:33 EDT
*** Bug 19241 has been marked as a duplicate of this bug. ***
Comment 13 Mark Toner 2001-09-05 15:45:11 EDT
This seems to be related to a problem that I have with my trident cyber 9320 
card. I am using XFree86 4.0.3 with Redhat 7.1. I can get Xwindows with no 
difficulty, provided I stick to a 640x480 8 bit display. This relies only on 
the generic VGA X Server.

When I try to use 800x600 8 bit, which is what my LCD display is designed to 
show (640x480 is blech!) I get no display at all - black screen.

This has been noted with cyber cards as far back as XFree86 4.0.1 and is due to 
the trident X server being broken. Can somebody please fix this thing before 
XFree86 4.0.4 comes out, or reinstate the SVGA server which worked just fine in 
the earlier versions.

I'm now having to struggle on with Redhat 7.1 and XFree86 taken from Redhat 6.2 
and it's broken a lot of the GNU programs (it's annoying when the terminal 
emulators don't work!). I may just have to go back to 6.2 and give up 7.1 as a 
lost cause.
Comment 14 Mike A. Harris 2002-01-25 02:14:01 EST
XFree86 3.3.6 X servers are included with ALL 7.x releases of Red Hat Linux,
so there is never a need to use the X servers from RHL 6.2.  Just install
the 3.3.6 server, and use it, right off the RHL 7.0/7.1/7.2 CD's.

Xconfigurator --preferxf3   forces the usage of the 3.3.6 server.

XFree86 4.2.0 in rawhide might solve these Trident issues, however you
need RHL 7.2 in order to use it.

If either solution works for you, please close the bug report with
RAWHIDE or WORKSFORME.

Thanks.
Comment 15 Brent Fox 2003-05-25 11:58:57 EDT
Closing since we don't ship the 3.3.x XFree86 packages anymore.

Note You need to log in before you can comment on or make changes to this bug.