Bug 191096 - Unable to install Fedora in Turkish language, anaconda crashes
Unable to install Fedora in Turkish language, anaconda crashes
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
All Linux
high Severity high
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
: 244016 (view as bug list)
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
Reported: 2006-05-08 16:49 EDT by Musa Serdar ARSLAN
Modified: 2009-09-21 17:14 EDT (History)
7 users (show)

See Also:
Fixed In Version: 2.5-15.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-21 22:30:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Anaconda error dump file. (62.25 KB, text/plain)
2006-05-08 16:49 EDT, Musa Serdar ARSLAN
no flags Details
rawhide traceback (71.36 KB, text/plain)
2007-03-05 15:21 EST, David Cantrell
no flags Details
Fedora 8 Oct24 Rawhide iso - Turkish locale crash issue - traceback (1.08 KB, text/plain)
2007-10-30 03:37 EDT, Devrim GUNDUZ
no flags Details

  None (edit)
Description Musa Serdar ARSLAN 2006-05-08 16:49:20 EDT
Description of problem: I tried to install Fedora Core 5 from the DVD that I
received from Linux-Magazine. But the installer aborted with an error after
setting up the installation partition. It also created an error dump file and it
is attached to bug report.

Version-Release number of selected component (if applicable): Fedora Core 5

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Musa Serdar ARSLAN 2006-05-08 16:49:20 EDT
Created attachment 128766 [details]
Anaconda error dump file.
Comment 2 David Cantrell 2006-05-09 10:50:15 EDT
The dump file shows more or less supported hardware and that it passed the

What kind of existing filesystems and/or LVM groups do you have?  Did you select
autopartitioning or did you define your own partitions?
Comment 3 Musa Serdar ARSLAN 2006-05-09 15:18:14 EDT
I have several partitions on my hard drive. I chose one of the previous
partitions . There was a debian linux installation on that partition. I assigned
that partition as the root partition. Evertyhting was fine until the installer
started to check the installation packages. Then I got the error and the
installation aborted with the dump file.
Comment 4 Musa Serdar ARSLAN 2006-05-11 16:51:36 EDT
I found out that this problem occurs when I choose Turkish Language support. If
I do not choose Turkish support installation continues smoothly. I think there
is a problem with the Turkish support only. Maybe the problem is for the DVD I have.
Comment 5 David Cantrell 2007-03-05 15:20:19 EST
This bug (or one similar to it) is still present in rawhide.  Attaching dump
report to this message.  Pulling in resident i18n anaconda expert (katzj).
Comment 6 David Cantrell 2007-03-05 15:21:09 EST
Created attachment 149287 [details]
rawhide traceback
Comment 7 Baris Cicek 2007-06-13 13:58:02 EDT
*** Bug 244016 has been marked as a duplicate of this bug. ***
Comment 8 Sertaç Ö. Yıldız 2007-06-13 14:08:24 EDT
This looks like a duplicate of bug #207134
Comment 9 Sertaç Ö. Yıldız 2007-06-13 21:55:09 EDT
hmm, not actually a duplicate but same code as in bug #207134.

Calling tolower() at get_normal_name() function in Parser/tokenizer.c causes this.
Comment 10 Stepan Kasal 2007-08-07 06:11:33 EDT
Indeed, this seems extremely important.

Sertaç Ö. Yıldız witnesses that F8test1 still cannot be installed in Turkish:

Comment 11 Devrim GUNDUZ 2007-10-26 21:57:58 EDT
This problem continues for test3, too -- I'm adding this as a blocker for F8.
Comment 12 Rahul Sundaram 2007-10-28 18:22:47 EDT
(Reassigning to Anaconda)

Has anyone tried the latest rawhide image?


If not, can you try and report back if it is fixed in that. We only got a couple
of days if we need to fix this on time. 
Comment 13 Devrim GUNDUZ 2007-10-28 18:31:25 EDT
I haven't tried it -- but now downloading the iso.
Comment 14 Jeremy Katz 2007-10-28 20:10:40 EDT
I just tried with rawhide of a day or so ago and things are fine.  The initial
traceback reported here was fixed as of the middle of September.
Comment 15 Sertaç Ö. Yıldız 2007-10-28 20:40:07 EDT
(In reply to comment #14)
> The initial traceback reported here was fixed as of the middle of September.

Do you mean python-2.5.1-11? Didn't test3 already contain that version?
Comment 16 Jens Petersen 2007-10-29 04:00:54 EDT
I installed a rawhide tree from the end of last week in Turkish successfully.
Do you still see a problem?
Comment 17 Devrim GUNDUZ 2007-10-29 14:03:50 EDT
Ok, I can confirm that the problem is solved with the latest rawhide.

You may close the ticket.

Regards, Devrim
Comment 18 Devrim GUNDUZ 2007-10-29 14:05:41 EDT
Oops, it crashed again after formatting the disk and starting installation.
Comment 19 Jeremy Katz 2007-10-29 14:24:19 EDT
Can you attach the exception you received?
Comment 20 Jens Petersen 2007-10-30 02:29:38 EDT
[Above I tested i386 install: x86_64 install over nfs (again from last week)
also looks ok for me FWIW.]
Comment 21 Devrim GUNDUZ 2007-10-30 03:37:49 EDT
Created attachment 242911 [details]
Fedora 8 Oct24 Rawhide iso - Turkish locale crash issue - traceback
Comment 22 Devrim GUNDUZ 2007-10-30 03:38:25 EDT
Attached is the traceback that I got.

Sorry for the delay.

Regards, Devrim
Comment 23 Jeremy Katz 2007-10-30 11:56:10 EDT
Okay, the original bug reported here is fixed and network installs work as
things are right now.  Devrim's traceback is a new bug and is directly bug
207134.  So I'm going to close this one and stick 207134 on the blocker list also
Comment 24 Sertaç Ö. Yıldız 2007-10-30 12:27:54 EDT
Removing the offending coding declarations from sqlite packages didn't fix this
bug, just palliated the installation problem it caused.

Shouldn't we leave this bug open till bug #207134 gets fixed and port the fix here?
Comment 25 Fedora Update System 2007-11-09 18:51:20 EST
python-2.5-15.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python'
Comment 26 Fedora Update System 2007-11-21 22:30:03 EST
python-2.5-15.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Sertaç Ö. Yıldız 2008-02-22 09:11:32 EST
As this bug report and bug #207134 are both closed, is there another open ticket
that I can track the status of python in Fedora with Turkish locale so that I
can change my locale back to Turkish when the issues[1] are fixed?

[1] http://bugs.python.org/issue1813

Note You need to log in before you can comment on or make changes to this bug.