Bug 191096 - Unable to install Fedora in Turkish language, anaconda crashes
Summary: Unable to install Fedora in Turkish language, anaconda crashes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: James Antill
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 244016 (view as bug list)
Depends On:
Blocks: F8Blocker
TreeView+ depends on / blocked
 
Reported: 2006-05-08 20:49 UTC by Musa Serdar ARSLAN
Modified: 2009-09-21 21:14 UTC (History)
7 users (show)

Fixed In Version: 2.5-15.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-22 03:30:12 UTC
Type: ---


Attachments (Terms of Use)
Anaconda error dump file. (62.25 KB, text/plain)
2006-05-08 20:49 UTC, Musa Serdar ARSLAN
no flags Details
rawhide traceback (71.36 KB, text/plain)
2007-03-05 20:21 UTC, David Cantrell
no flags Details
Fedora 8 Oct24 Rawhide iso - Turkish locale crash issue - traceback (1.08 KB, text/plain)
2007-10-30 07:37 UTC, Devrim GUNDUZ
no flags Details

Description Musa Serdar ARSLAN 2006-05-08 20:49:20 UTC
Description of problem: I tried to install Fedora Core 5 from the DVD that I
received from Linux-Magazine. But the installer aborted with an error after
setting up the installation partition. It also created an error dump file and it
is attached to bug report.


Version-Release number of selected component (if applicable): Fedora Core 5


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Musa Serdar ARSLAN 2006-05-08 20:49:20 UTC
Created attachment 128766 [details]
Anaconda error dump file.

Comment 2 David Cantrell 2006-05-09 14:50:15 UTC
The dump file shows more or less supported hardware and that it passed the
mediacheck.

What kind of existing filesystems and/or LVM groups do you have?  Did you select
autopartitioning or did you define your own partitions?

Comment 3 Musa Serdar ARSLAN 2006-05-09 19:18:14 UTC
I have several partitions on my hard drive. I chose one of the previous
partitions . There was a debian linux installation on that partition. I assigned
that partition as the root partition. Evertyhting was fine until the installer
started to check the installation packages. Then I got the error and the
installation aborted with the dump file.

Comment 4 Musa Serdar ARSLAN 2006-05-11 20:51:36 UTC
I found out that this problem occurs when I choose Turkish Language support. If
I do not choose Turkish support installation continues smoothly. I think there
is a problem with the Turkish support only. Maybe the problem is for the DVD I have.

Comment 5 David Cantrell 2007-03-05 20:20:19 UTC
This bug (or one similar to it) is still present in rawhide.  Attaching dump
report to this message.  Pulling in resident i18n anaconda expert (katzj).

Comment 6 David Cantrell 2007-03-05 20:21:09 UTC
Created attachment 149287 [details]
rawhide traceback

Comment 7 Baris Cicek 2007-06-13 17:58:02 UTC
*** Bug 244016 has been marked as a duplicate of this bug. ***

Comment 8 Sertaç Ö. Yıldız 2007-06-13 18:08:24 UTC
This looks like a duplicate of bug #207134

Comment 9 Sertaç Ö. Yıldız 2007-06-14 01:55:09 UTC
hmm, not actually a duplicate but same code as in bug #207134.

Calling tolower() at get_normal_name() function in Parser/tokenizer.c causes this.

Comment 10 Stepan Kasal 2007-08-07 10:11:33 UTC
Indeed, this seems extremely important.

Sertaç Ö. Yıldız witnesses that F8test1 still cannot be installed in Turkish:

http://www.redhat.com/archives/fedora-devel-list/2007-August/msg00354.html

Comment 11 Devrim GUNDUZ 2007-10-27 01:57:58 UTC
This problem continues for test3, too -- I'm adding this as a blocker for F8.

Comment 12 Rahul Sundaram 2007-10-28 22:22:47 UTC
(Reassigning to Anaconda)

Has anyone tried the latest rawhide image?

http://torrent.fedoraproject.org/

If not, can you try and report back if it is fixed in that. We only got a couple
of days if we need to fix this on time. 

Comment 13 Devrim GUNDUZ 2007-10-28 22:31:25 UTC
I haven't tried it -- but now downloading the iso.

Comment 14 Jeremy Katz 2007-10-29 00:10:40 UTC
I just tried with rawhide of a day or so ago and things are fine.  The initial
traceback reported here was fixed as of the middle of September.

Comment 15 Sertaç Ö. Yıldız 2007-10-29 00:40:07 UTC
(In reply to comment #14)
> The initial traceback reported here was fixed as of the middle of September.

Do you mean python-2.5.1-11? Didn't test3 already contain that version?

Comment 16 Jens Petersen 2007-10-29 08:00:54 UTC
I installed a rawhide tree from the end of last week in Turkish successfully.
Do you still see a problem?

Comment 17 Devrim GUNDUZ 2007-10-29 18:03:50 UTC
Ok, I can confirm that the problem is solved with the latest rawhide.

You may close the ticket.

Regards, Devrim

Comment 18 Devrim GUNDUZ 2007-10-29 18:05:41 UTC
Oops, it crashed again after formatting the disk and starting installation.

Comment 19 Jeremy Katz 2007-10-29 18:24:19 UTC
Can you attach the exception you received?

Comment 20 Jens Petersen 2007-10-30 06:29:38 UTC
[Above I tested i386 install: x86_64 install over nfs (again from last week)
also looks ok for me FWIW.]

Comment 21 Devrim GUNDUZ 2007-10-30 07:37:49 UTC
Created attachment 242911 [details]
Fedora 8 Oct24 Rawhide iso - Turkish locale crash issue - traceback

Comment 22 Devrim GUNDUZ 2007-10-30 07:38:25 UTC
Attached is the traceback that I got.

Sorry for the delay.

Regards, Devrim

Comment 23 Jeremy Katz 2007-10-30 15:56:10 UTC
Okay, the original bug reported here is fixed and network installs work as
things are right now.  Devrim's traceback is a new bug and is directly bug
207134.  So I'm going to close this one and stick 207134 on the blocker list also

Comment 24 Sertaç Ö. Yıldız 2007-10-30 16:27:54 UTC
Removing the offending coding declarations from sqlite packages didn't fix this
bug, just palliated the installation problem it caused.

Shouldn't we leave this bug open till bug #207134 gets fixed and port the fix here?


Comment 25 Fedora Update System 2007-11-09 23:51:20 UTC
python-2.5-15.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python'

Comment 26 Fedora Update System 2007-11-22 03:30:03 UTC
python-2.5-15.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 27 Sertaç Ö. Yıldız 2008-02-22 14:11:32 UTC
As this bug report and bug #207134 are both closed, is there another open ticket
that I can track the status of python in Fedora with Turkish locale so that I
can change my locale back to Turkish when the issues[1] are fixed?

[1] http://bugs.python.org/issue1813


Note You need to log in before you can comment on or make changes to this bug.