Bug 191133 - Segmentation fault with gstreamer
Segmentation fault with gstreamer
Status: CLOSED DUPLICATE of bug 192954
Product: Fedora
Classification: Fedora
Component: libdv (Show other bugs)
5
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Jarod Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-08 22:56 EDT by Manuel Alejandro Cerón Estrada
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-24 10:39:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manuel Alejandro Cerón Estrada 2006-05-08 22:56:51 EDT
Description of problem:

Libdv segfaults when is called from gstreamer 

Version-Release number of selected component (if applicable):

0.104-2

Steps to Reproduce:
1. open a console.
2. gst-launch-0.10 playbin uri=file:///path.to/file.dv

A test dv file can be downloaded from http://svn.diva-project.org/media/

Actual results:
Segmentation Fault.

Expected results:
A X window playing the clip.
Comment 1 Jarod Wilson 2006-05-11 12:30:47 EDT
Interesting... The crash appears to be i386-specific, works fine on my x86_64
box, but does segfault on a 32-bit test box. I'll see what I can see...
Comment 2 Jarod Wilson 2006-05-12 15:04:26 EDT
[...]
(gdb) bt
#0  0x00b9778c in dv_parse_ac_coeffs_pass0@plt () from /usr/lib/libdv.so.4
#1  0x00ba8b57 in dv_parse_video_segment () from /usr/lib/libdv.so.4
#2  0xb7320870 in ?? ()
#3  0xb73230e0 in ?? ()
#4  0x00baf16c in ?? () from /usr/lib/libdv.so.4
#5  0x00b98f6a in dv_decode_full_frame () from /usr/lib/libdv.so.4
Previous frame inner to this frame (corrupt stack?)
Comment 3 Jarod Wilson 2006-05-24 10:39:24 EDT
Marking this one as a duplicate of 192954 instead of vice versa, because the
title of the other one makes it more obvious exactly what's going on -- dv
decoding being broken.

*** This bug has been marked as a duplicate of 192954 ***

Note You need to log in before you can comment on or make changes to this bug.