Bug 192954 - dv decoding segfaults
dv decoding segfaults
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libdv (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
:
: 191133 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-24 10:34 EDT by Thomas Vander Stichele
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-24 16:56:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Vander Stichele 2006-05-24 10:34:25 EDT
Description of problem:

Decoding dv files consistently segfault


Version-Release number of selected component (if applicable):
0.104-2

How reproducible:
always

Steps to Reproduce:
1. connectdv raw.dv
2. playdv raw.dv
3.

Exact same bug shows up by running:
dvgrab --format jpg

or

gst-launch-0.10 dv1394src ! dvdemux ! dvdec ! fakesink

Actual results:

segfault

Expected results:

workie !
Additional info:
I had someone try on ubuntu with 0.104, works.  Same for Gentoo.  will
investigate further, likely one of the fedora patches is causing it.
Comment 1 Jarod Wilson 2006-05-24 10:39:36 EDT
*** Bug 191133 has been marked as a duplicate of this bug. ***
Comment 2 Thomas Vander Stichele 2006-05-24 11:31:26 EDT
Hehe, this has been fun.

Some more feedback:

- the gentoo user who tested it actually had a self-compiled version, precisely
because he ran into this bug a year ago
- another gentoo user, which was using the 0.104 package, also runs into the bug
- a debian user does not have this bug

Other references to the exact same bug:
http://bugs.gentoo.org/show_bug.cgi?id=121871
http://bugzilla.gnome.org/show_bug.cgi?id=338003
http://sourceforge.net/mailarchive/forum.php?thread_id=10148653&forum_id=5458

- I did some testing - if I remove the pic patch, everything works fine for me.
 In addition, on Ubuntu and Debian, this is one of the patches that they do not
use.  One ubuntu user is using it on x86_64 without problems, so I'm assuming
there is no PIC problem to begin with.

I suggest a rebuild of this package with new release, and the patch removed. 
I'll be pushing this package myself to the GStreamer repository.
Comment 3 Thomas Vander Stichele 2006-05-24 11:57:02 EDT
Ok, one more datapoint.  I tested a 64 bit FC5 machine with the Fedora package -
works fine.

I tested the package with that pic patch removed - still works fine.

I'm 
Comment 4 Jarod Wilson 2006-05-24 12:12:28 EDT
Yup, the current FC5/x86_64 package works for me too. I'll chat with some folks
here and see if we can't fix the pic patch, rather than remove it.
Comment 5 Jarod Wilson 2006-05-24 15:53:29 EDT
It looks like x86_64 isn't affected, because the PIC patch only touches x86 asm.
For the moment, I'm just going to back out the patch while investigating the fix
(trying to get in touch with the maintainer(s) about it).

Note You need to log in before you can comment on or make changes to this bug.