Bug 1912436 - python-networkx: FTBFS in Fedora rawhide
Summary: python-networkx: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: python-networkx
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jerry James
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F34FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-01-04 13:31 UTC by Tomáš Hrnčiar
Modified: 2021-01-24 04:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-24 04:45:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-01-04 13:31:14 UTC
Description of problem:
Package python-networkx fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
2.5-2.fc34

Steps to Reproduce:
koji build --scratch f34 python-networkx-2.5-2.fc34.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-networkx

+ rst2html --no-datestamp README.rst README.html
free(): invalid pointer
/var/tmp/rpm-tmp.mTF4Lt: line 39:   154 Aborted                 (core dumped) rst2html --no-datestamp README.rst README.html

I suspect PIL (pillow) is broken. See also bz1899498 and bz1898977.

Comment 1 Jerry James 2021-01-04 18:20:17 UTC
I just did a mock build like so:

$ mock -r fedora-rawhide-x86_64 --enablerepo=local --rebuild python-networkx-2.5-2.fc34.src.rpm

That did NOT exhibit the problem.  In any case, if rst2html is crashing, that's a bug in python3-docutils, not python-networkx, right?

Comment 2 Fedora Release Engineering 2021-01-24 04:22:22 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 34.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-03-01).

A week before the mass branching of Fedora 35 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 33 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-35/f-35-key-tasks.html

Comment 3 Jerry James 2021-01-24 04:45:34 UTC
The bug was not in python-networkx and has since been fixed.  Closing.


Note You need to log in before you can comment on or make changes to this bug.