Bug 1915437 - gcc-11.0.0-0.12.fc34 segfaults while building clang
Summary: gcc-11.0.0-0.12.fc34 segfaults while building clang
Keywords:
Status: CLOSED DUPLICATE of bug 1915400
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1915792 (view as bug list)
Depends On:
Blocks: F34FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-01-12 16:14 UTC by Tom Stellard
Modified: 2021-01-13 18:49 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-13 18:49:56 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNU Compiler Collection 98597 0 P1 ASSIGNED [11 Regression] ICE in print_mem_ref since r11-6508-gabb1b6058c09a7c0 2021-01-12 16:49:07 UTC

Description Tom Stellard 2021-01-12 16:14:04 UTC
Description of problem:
Koschei detected a build failure of clang with the latest version of gcc: https://koschei.fedoraproject.org/build/9617244

Version-Release number of selected component (if applicable):
https://koschei.fedoraproject.org/build/9617244

How reproducible:
Always

Steps to Reproduce:
1. Do a mock build or scratch build of clang with gcc-11.0.0-0.12.fc34.

Actual results:

Build failures with the error:

*** WARNING *** there are active plugins, do not report this as a bug unless you can reproduce it without enabling any plugins.
Event                            | Plugins
PLUGIN_FINISH_UNIT               | annobin: Generate final annotations
PLUGIN_START_UNIT                | annobin: Generate global annotations
PLUGIN_ALL_PASSES_START          | annobin: Generate per-function annotations
PLUGIN_ALL_PASSES_END            | annobin: Register per-function end symbols
during GIMPLE pass: uninit
In function 'void EvaluateFeatureLikeBuiltinMacro.constprop(llvm::raw_svector_ostream&, clang::Token&, clang::IdentifierInfo*, clang::Preprocessor&, llvm::function_ref<int(clang::Token&, bool&)>)':
Segmentation fault
 1286 | static void EvaluateFeatureLikeBuiltinMacro(llvm::raw_svector_ostream& OS,
      |             ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
0x1147242f diagnostic_impl(rich_location*, diagnostic_metadata const*, int, char const*, char**, diagnostic_t)
	???:0
0x1084fee3 internal_error(char const*, ...)
	???:0
0x10444f9b crash_signal(int)
	???:0
0x1027fc00 print_mem_ref(c_pretty_printer*, tree_node*)
	???:0
0x1091af27 dump_expr(cxx_pretty_printer*, tree_node*, int) [clone .constprop.0]
	???:0
0x101f4a17 expr_to_string(tree_node*)
	???:0
0x1103941f cp_printer(pretty_printer*, text_info*, char const*, int, bool, bool, bool, bool*, char const**)
	???:0
0x11477b4b pp_format(pretty_printer*, text_info*)
	???:0
0x10ff8793 diagnostic_report_diagnostic(diagnostic_context*, diagnostic_info*)
	???:0
0x10ff91e7 warning_at(unsigned int, int, char const*, ...)
	???:0
0x10d4ab9b warn_uninit(opt_code, tree_node*, tree_node*, tree_node*, char const*, void*, unsigned int)
	???:0
0x10d4bedf (anonymous namespace)::pass_late_warn_uninitialized::execute(function*)
	???:0

Expected results:

Build succeeds.

Comment 1 Jakub Jelinek 2021-01-12 16:17:43 UTC
Martin Sebor, again your change.

Comment 2 Martin Sebor 2021-01-12 16:49:48 UTC
This is a duplicate of bug 1915400, tracked upstream in https://gcc.gnu.org/bugzilla/show_bug.cgi?id=98597.

Comment 3 Tom Stellard 2021-01-13 13:00:15 UTC
*** Bug 1915792 has been marked as a duplicate of this bug. ***

Comment 4 Jeff Law 2021-01-13 18:49:56 UTC

*** This bug has been marked as a duplicate of bug 1915400 ***


Note You need to log in before you can comment on or make changes to this bug.