Bug 191591 - Gnucash field suggestions no longer works with 1.8.0
Summary: Gnucash field suggestions no longer works with 1.8.0
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnucash   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 193328 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-13 15:43 UTC by Paul Dickson
Modified: 2014-03-17 02:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-24 02:11:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Dickson 2006-05-13 15:43:38 UTC
Description of problem:
Prior to guile 1.8.0 register input fields were filled in as you typed, allowing
tab to be pressed once the correct field is found.  Now, after the first key is
pressed in a field and the value is guessed, all subsequent key presses are
insert inside the guessed value.

Version-Release number of selected component (if applicable):
guile-1.8.0-2
gnucash-1.9.5-3

How reproducible:
Always

Steps to Reproduce:
1. Open a register
2. Enter a transaction (or have a transaction already entered) with a value like
"tshirts x4".
3. Start typing in a new transaction with a field value like "tshirts x2".
  
Actual results:
As you type "tshirts x2", "tshirts x4" will pop up.  Then "tshshirts x4" as you
type the second and third characters.

Expected results:
As you type "tshirts x2", "tshirts x4" will pop up.  "tshirts x4" stays
suggested until either you hit tab, backspace, and then "2"; or until you type a
character not in the string "tshirts x4".

Additional info:
I'm not sure whether this is a guile bug or a gnucash bug, but since the only
apparent code change is a new version of guile, I believe the guilt resides there.

Comment 1 Miroslav Lichvar 2006-05-15 16:39:29 UTC
gnucash-1.9.5-3 with guile-1.8.0-2, g-wrap-1.9.6-4, slib-3a3-1 doesn't show this
problem on FC5, but on devel does. Maybe something else has changed?

Comment 2 Paul Dickson 2006-05-16 12:51:51 UTC
I'm trying to revert gtk2 to see what that dones:

rpm -Uvh --oldpackage gtk2-devel-2.8.17-2.i386.rpm gtk2-engines-2.7.4-6.i386.rpm\
   gtk2-2.8.17-2.i386.rpm librsvg2-devel-2.14.3-2.i386.rpm \
   librsvg2-2.14.3-2.i386.rpm redhat-artwork-0.241-1.i386.rpm \
   libwmf-0.2.8.4-6.i386.rpm libgnomeui-2.14.1-2.i386.rpm \
   libgnomeui-devel-2.14.1-2.i386.rpm

This got me:
$ gnucash
gnucash-bin: error while loading shared libraries: libgnomeui-2.so.0: cannot
open shared object file: No such file or directory

Is this an unlisted dependency?


Comment 3 Bill Nottingham 2006-05-16 19:57:36 UTC
Will do some testing. Can you get this upstream as well?

I should probably build some test packages for FC5 to help diagnose these things.

Comment 4 Paul Dickson 2006-05-17 17:40:26 UTC
After the above error in #2, I revert gnucash (and compatible version of guile).
 I then ended up with the errors:

$ gnucash
<unnamed port>: In expression (user-vicinity):
<unnamed port>: Unbound variable: user-vicinity
$

This was from both previous versions of 1.9.5 and 1.9.4 of gnucash.

Comment 5 Paul Dickson 2006-05-17 21:16:01 UTC
Posted as: http://bugzilla.gnome.org/show_bug.cgi?id=342182

Comment 6 Bill Nottingham 2006-05-18 21:09:52 UTC
Fairly certain this isn't guile-related. Pushing to gnucash.

Comment 7 Bill Nottingham 2006-05-24 02:11:26 UTC
Closing, will be fixed with a rebase to 1.9.7.

Comment 8 Bill Nottingham 2006-05-30 06:25:52 UTC
*** Bug 193328 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.