Bug 191650 - Support fontconfig SubPixel attributes
Support fontconfig SubPixel attributes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-14 12:07 EDT by sangu
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.0.3-4.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-30 08:40:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
UI font rendering screenshot (79.64 KB, image/png)
2006-05-14 12:07 EDT, sangu
no flags Details
Hinting is Good. (159.88 KB, image/png)
2006-05-31 00:53 EDT, sangu
no flags Details

  None (edit)
Description sangu 2006-05-14 12:07:45 EDT
Created attachment 129009 [details]
UI font rendering screenshot
Comment 1 sangu 2006-05-14 12:07:45 EDT
Description of problem:
UI font rendering is different  to the others gtk2 program.
maybe hinting problem?

Version-Release number of selected component (if applicable):
2.0.3-0.169.3

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
rebuild freetype for byteinterpreter.

UI font :
 * Korean : Malgun Gothic 
 * English : Segoe UI

locale ko_KR.UTF-8
Comment 2 Caolan McNamara 2006-05-15 05:36:39 EDT
It's quite likely that there's a small fix required for get the hinting mapping
the same as the pango/gtk one, autohint vs non auto-hint hinting type or
something like that, but is there a rpm available with "Malgun Gothic" in it ?
Or where does it come from.
Comment 3 sangu 2006-05-15 06:12:20 EDT
Malgun gothic is MS Vista new default Korean font. 
Comment 4 Caolan McNamara 2006-05-16 03:54:59 EDT
*** Bug 191840 has been marked as a duplicate of this bug. ***
Comment 5 Caolan McNamara 2006-05-18 05:43:49 EDT
sangu: Can your hinting issue be reproduced (in devel) with any fonts available
for me to test with? Malgun Gothic is not available unless I have windows vista,
which I don't of course :-)
Comment 6 Caolan McNamara 2006-05-22 05:34:10 EDT
I'd love to be able to fix this, is there any other font that causes a similiar
problem that I could work with ?
Comment 7 Caolan McNamara 2006-05-22 09:18:43 EDT
I think I've identified the problem, I have a similiar looking problem with
"Bitstream Charter"
Comment 8 sangu 2006-05-25 23:44:06 EDT
Sorry about delay response.

This problem still happens in openoffice.org-core-2.0.3-3.2

This url is malgun gothic.

http://blogfile.paran.com/BLOG_237530/200602/1140334125_malgun.rar
http://blogfile.paran.com/BLOG_237530/200602/1140334125_malgunbd.rar

Using Meiryo for Japanese, Microsoft JhengHei for Chinese (Traditional),
Microsoft YaHei for Chinese (Simplified), this same problem will happen, maybe.

The fonts are cjk fonts which include cleartype(subpixel) and hinting.
Comment 9 Caolan McNamara 2006-05-26 08:42:56 EDT
I see this (other problem) now I think, GF_UNHINTED is hardcoded against not
having the TT BYTECODEINTERPTER available at compile time

#if !defined(TT_CONFIG_OPTION_BYTECODE_INTERPRETER)
    // #95556# autohinting not yet optimized for non-western glyph styles
    if( !(mnLoadFlags & (FT_LOAD_NO_HINTING | FT_LOAD_FORCE_AUTOHINT) )
    &&  ( (aChar >= 0x0600 && aChar < 0x1E00)   // south-east asian + arabic
        ||(aChar >= 0x2900 && aChar < 0xD800)   // CJKV
        ||(aChar >= 0xF800) ) )                 // presentation + symbols
        nGlyphFlags |= GF_UNHINTED;
#endif

got a new fix for that now...
Comment 10 Caolan McNamara 2006-05-30 23:35:04 EDT
excellent
Comment 11 sangu 2006-05-31 00:53:14 EDT
Created attachment 130256 [details]
Hinting is Good. 

Good, Excellent, Beautiful... :)

Note You need to log in before you can comment on or make changes to this bug.