Bug 191840 - OpenOffice.org fonts rendering is broken : bad hinting
Summary: OpenOffice.org fonts rendering is broken : bad hinting
Status: CLOSED DUPLICATE of bug 192234
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-16 00:54 UTC by Gilles Gagniard
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-16 07:54:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of OpenOffice.org and Epiphany. (88.32 KB, image/png)
2006-05-16 00:54 UTC, Gilles Gagniard
no flags Details

Description Gilles Gagniard 2006-05-16 00:54:07 UTC
Description of problem:
The fonts in OpenOffice.org are very blurry, almost unreadable for tiny sizes.
When antialiasing is deactivated, the fonts are choppy and irregular, probably
indicating a hinting problem.

Version-Release number of selected component (if applicable): 2.0.2-5.9.2

How reproducible: Always.

Steps to Reproduce:
1. Start OpenOffice.org
2. Look at it
3.
  
Actual results:
The fonts look completely blurry, almost unreadable. It only happen in
OpenOffice.org, fonts in GTK/QT apps are perfect.


Expected results:
The fonts have the same rendering/hinting quality in OpenOffice.org and in all
the other applications, eg not blurry and crisp.

Additional info:
Please find a screenshot attached. It shows an OpenOffice window and an Epiphany
window. The problem can easily be understood by comparing both menu bars :
OpenOffice is the only application where hinting seems to be broken.

Comment 1 Gilles Gagniard 2006-05-16 00:54:07 UTC
Created attachment 129147 [details]
Screenshot of OpenOffice.org and Epiphany.

Comment 2 Caolan McNamara 2006-05-16 07:54:45 UTC

*** This bug has been marked as a duplicate of 191650 ***

Comment 3 Caolan McNamara 2006-05-16 08:59:36 UTC
What's your "System->Preferences->fonts->Application font:" ?

Comment 4 Caolan McNamara 2006-05-19 16:59:07 UTC

*** This bug has been marked as a duplicate of 192234 ***

Comment 5 Gilles Gagniard 2006-05-24 00:28:32 UTC
The Application Font is Verdana 9 ... but I don't think it's the problem.
Actually, every single font has the same problem in OpenOffice. I can attach a
screenshot if necessary.

I think this bug is definitely the same than #191650, but it's broader than
described, every font is affected.

Comment 6 Caolan McNamara 2006-05-25 11:12:26 UTC
It's probably not the specific bug 191650, but that of bug 192234, try the
update and see if it fixes your problem.


Note You need to log in before you can comment on or make changes to this bug.