Bug 191679 - Update FC4 -> FC5 (by CDs) fails with Anaconda exception
Update FC4 -> FC5 (by CDs) fails with Anaconda exception
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-15 00:27 EDT by Wolf Siedler
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-26 15:51:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dumpfile created by Anaconda (131.10 KB, text/plain)
2006-05-15 00:27 EDT, Wolf Siedler
no flags Details
Partition layout of hdd where CD upgrade fails (3.45 KB, text/plain)
2006-05-18 23:55 EDT, Wolf Siedler
no flags Details

  None (edit)
Description Wolf Siedler 2006-05-15 00:27:09 EDT
Description of problem:
Upgrade from FC4 to FC5 fails with an Anaconda exception.

My system contains an HPFS pertition. However, even mount disabling of that
partition in /etc/fstab (sort of derived from bug 186998) did not solve the problem.

How reproducible:
I tried to upgrade my FC4 installation through the standard FC5 CDs.

Actual results:
Anaconda still fails in grahical and text mode.

Expected results:
Enable update of existing FC4 system.

Additional info:
Due to extensive customization, I would appreciate if a completely new
installation could be avoided.
My system is currently using a custom-built kernel (2.6.16-1.2108) with enabled
Software Suspend2 and HPFS support.
Comment 1 Wolf Siedler 2006-05-15 00:27:09 EDT
Created attachment 129033 [details]
Dumpfile created by Anaconda
Comment 2 Chris Lumens 2006-05-16 17:37:31 EDT
Could you please attach a complete list of your partitions and what type each
is?   Also, do you have an operating system suspended while you're trying to
upgrade?
Comment 3 Wolf Siedler 2006-05-18 23:55:05 EDT
Created attachment 129579 [details]
Partition layout of hdd where CD upgrade fails

The layout was created by the partioning software DFSEE.
The forth column (this is a bit abbreviated) gives the partion IDs under Linux.


In case it helps:
The notebook is booted through an alternative boot manager called AiR-Boot
which resides in the MBR.
When booting FC from AiR-Boot, grub in /dev/hda1 is called.
The IBM-boot manager in /dev/hda2 is not used anymore.

And no, there were are no suspended other operating systems active during the
attempted upgrade.
Comment 4 Wolf Siedler 2006-05-25 00:36:52 EDT
Sorry, I was imprecise: "no other suspended operating systems active" should of
course mean that no other OS was suspended at that time.

Furthermore, after rechecking the Anaconda dump file, I noticed that it
complained about duplicate partition labels.

I find this strange because I believe that there are no such duplicate names
left. Indeed there were at first such duplicates as a result of a relocation of
/ and /home partitions. However, I believe that they have been long since
cleared by using:
e2label /dev/hda17 "" (one sample, /dev/hda17 being - iirc - the old / partition)
Besides the / resp. /home label was applied to the new (current) such partitions.

If I overlooked something here, please let me know!
Comment 5 Chris Lumens 2007-03-26 15:51:06 EDT
It looks like somehow, a device on your system has been given an invalid label.
 You're getting a traceback because we are trying to print a string that
contains some invalid characters.  Unfortunately, we don't have the debugging
information here to tell what device has the problem.  I've added an additional
dialog to catch this error and display the device in question.  Please try an
upgrade to F7 when it comes out and see if you still run into problems.  If so,
you should at least have an idea of what device needs to be fixed.  Thanks for
the bug report.

Note You need to log in before you can comment on or make changes to this bug.