Bug 191695 - php-pdo should obsolete php-pecl-pdo and php-pecl-pdo-sqlite
php-pdo should obsolete php-pecl-pdo and php-pecl-pdo-sqlite
Status: CLOSED DUPLICATE of bug 181863
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
: EasyFix
Depends On:
Blocks: 191625 191627
  Show dependency treegraph
Reported: 2006-05-15 06:44 EDT by Matthias Saou
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-16 11:25:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2006-05-15 06:44:24 EDT
For Fedora Core 4, it made sense to have these packages added in Extras :

But starting with FC5's PHP 5.1.2 there is now a main "php-pdo" sub-package
which contains the same thing as the two above. I will have them removed from
Extras for FC5 and FC development, but php-pdo will need to have :

Obsoletes: php-pecl-pdo <= 1.0.2-3
Obsoletes: php-pecl-pdo-sqlite <= 0.3-5

So that upgrades go smoothly. And eventually :

Provides: php-pecl-pdo = %{version}-%{release}
Provides: php-pecl-pdo-sqlite = %{version}-%{release}

Alhough I don't think those provides would be really useful, and wouldn't
reflect the actual module version as found on pecl.php.net, but have PHP's
version instead.

See bug #191625 and bug #191627 for the report of the initial problem.
Comment 1 Joe Orton 2006-05-16 11:25:55 EDT
Adding -pecl- provides for stuff now shipped in the PHP tarball doesn't make
sense, I think.  The Obsoletes have been there since the FC5 php.

*** This bug has been marked as a duplicate of 181863 ***

Note You need to log in before you can comment on or make changes to this bug.