Bug 191815 - escreensaver Missing BuildRequires
Summary: escreensaver Missing BuildRequires
Status: CLOSED DUPLICATE of bug 191769
Alias: None
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-15 22:29 UTC by Andreas Thienemann
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-17 23:01:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch, adding the missing buildreqs (452 bytes, patch)
2006-05-15 22:29 UTC, Andreas Thienemann
no flags Details | Diff
rpmdiff error for previous BR patch. (31.73 KB, text/plain)
2006-05-17 20:22 UTC, Brian Pepple
no flags Details
Correct BR patch (1.23 KB, patch)
2006-05-17 20:22 UTC, Brian Pepple
no flags Details | Diff
Build log after corrected BR patch (404.38 KB, text/plain)
2006-05-17 20:24 UTC, Brian Pepple
no flags Details

Description Andreas Thienemann 2006-05-15 22:29:40 UTC
Build fails with:

../../utils/grabclient.c:28:54: error: X11/Intrinsic.h: No such file or directory

Attached is a patch, fixing the missing BuildRequires for libjpeg-devel,
libXt-devel and libXmu-devel

Comment 1 Andreas Thienemann 2006-05-15 22:29:40 UTC
Created attachment 129130 [details]
Patch, adding the missing buildreqs

Comment 2 Mamoru TASAKA 2006-05-17 04:35:51 UTC
I think that the comment 1 is not enough.  I commented on this problem
to Bug 191769.


Comment 3 Andreas Thienemann 2006-05-17 10:21:16 UTC
Well, the Package builds fine with only libjpeg, libXt and libXmu development
packages installed.

But you were partly right: libXxf86vm-devel is needed, but most likely
libXxf86misc-devel is not.

Some of the packaged screensavers are linking against libXxf86vm.so.1 but
there's nothing needed from libXxf86misc-devel AFAIK.

Comment 4 Mamoru TASAKA 2006-05-17 11:15:23 UTC
I checked that xscreensaver can be build without libXxf86misc-devel, 
that is true.

However, libXxf86misc addes some extensional function to xscreensaver daemon.
See driver/lock.c and HAVE_XF86MISCSETGRABKEYSSTATE (although I don't know
what this is doing).

Comment 5 Brian Pepple 2006-05-17 20:22:15 UTC
Created attachment 129359 [details]
rpmdiff error for previous BR patch.

The previously attached BR patch doesn't contain all the necessary BR's. 
rpmdiff must be ran against the curent rawhide rpm to the ones you are building
in mock to find *ALL* the BR needed.  Refer to the wiki for more information,
if you are not clear.

http://fedoraproject.org/wiki/QA/FixBuildRequires

Comment 6 Brian Pepple 2006-05-17 20:22:55 UTC
Created attachment 129360 [details]
Correct BR patch

Comment 7 Brian Pepple 2006-05-17 20:24:51 UTC
Created attachment 129361 [details]
Build log after corrected BR patch

Comment 8 Brian Pepple 2006-05-17 23:01:25 UTC

*** This bug has been marked as a duplicate of 191769 ***


Note You need to log in before you can comment on or make changes to this bug.