Bug 191769 - xscreensaver fails to build using mock
xscreensaver fails to build using mock
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 191815 (view as bug list)
Depends On:
Blocks: 176218 BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-15 13:50 EDT by Alexander Täschner
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-05 17:16:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log of mock (8.96 KB, text/plain)
2006-05-15 13:50 EDT, Alexander Täschner
no flags Details
build.log of sucessful build (403.50 KB, text/plain)
2006-05-15 16:47 EDT, Alexander Täschner
no flags Details
Patch from bug #191815 (1.23 KB, patch)
2006-05-17 19:03 EDT, Brian Pepple
no flags Details | Diff

  None (edit)
Description Alexander Täschner 2006-05-15 13:50:54 EDT
Building the SRPM
http://download.fedora.redhat.com/pub/fedora/linux/core/5/source/SRPMS/xscreensaver-4.24-1.1.src.rpm
using mock fails.

Attached is the build.log.
Comment 1 Alexander Täschner 2006-05-15 13:50:54 EDT
Created attachment 129101 [details]
build.log of mock
Comment 2 Alexander Täschner 2006-05-15 16:47:05 EDT
Created attachment 129117 [details]
build.log of sucessful build

Adding the lines

BuildRequires:	libXt-devel libXmu-devel libjpeg-devel libXpm-devel
BuildRequires:	libXxf86vm-devel libXxf86misc-devel

to xscreensaver.spec soves the build problems.

Attached is the build log.
Comment 3 Mamoru TASAKA 2006-05-17 00:28:42 EDT
Hello.

Ray, I have already added these requirements to xscreensaver-4.24-3 which
I am to release in fedora-extras.
Comment 4 Mamoru TASAKA 2006-05-17 00:50:28 EDT
Bug 176218 can be closed when this bug is closed.
Comment 5 Brian Pepple 2006-05-17 19:01:53 EDT
*** Bug 191815 has been marked as a duplicate of this bug. ***
Comment 6 Brian Pepple 2006-05-17 19:03:45 EDT
Created attachment 129372 [details]
Patch from bug #191815
Comment 7 Jesse Keating 2006-06-05 17:16:34 EDT
Package was moved to Extras.

Note You need to log in before you can comment on or make changes to this bug.