Bug 191825 - Dependency on %{imake} making transfig unable to build in mock
Summary: Dependency on %{imake} making transfig unable to build in mock
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: transfig (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
: 191717 (view as bug list)
Depends On:
Blocks: BuildReqBlocker
TreeView+ depends on / blocked
 
Reported: 2006-05-15 23:11 UTC by Andreas Thienemann
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-16 08:18:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch, fixing the imake dependency (526 bytes, patch)
2006-05-15 23:11 UTC, Andreas Thienemann
no flags Details | Diff

Description Andreas Thienemann 2006-05-15 23:11:09 UTC
As 'which imake' is returning an empty result in a minimal buildroot, such as
one  mock creates, rpm sees an empty BuildRequire, making it bail.

Attached is a patch, which changes the %{imake} dependency to BuildRequire: imake.

This makes transfig compile in mock.

Comment 1 Andreas Thienemann 2006-05-15 23:11:09 UTC
Created attachment 129139 [details]
Patch, fixing the imake dependency

Comment 2 Andreas Thienemann 2006-05-15 23:12:28 UTC
*** Bug 191717 has been marked as a duplicate of this bug. ***

Comment 3 Ngo Than 2006-05-16 08:18:19 UTC
it's now fixed in rawhide. Thanks for youre report.


Note You need to log in before you can comment on or make changes to this bug.