Bug 191884 - setserial Package won't build in mock
setserial Package won't build in mock
Status: CLOSED DUPLICATE of bug 191883
Product: Fedora
Classification: Fedora
Component: setserial (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-16 06:43 EDT by Andreas Thienemann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-16 06:45:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Thienemann 2006-05-16 06:43:04 EDT
The package won't build in mock with the following error on x86_64:

+ ./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu
--target=x86_64-redhat-linux-gnu --program-prefix= --prefix=/usr
--exec-prefix=/usr --bindir=/bin --sbindir=/usr/sbin --sysconfdir=/etc
--datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64
--libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com
--mandir=/usr/share/man --infodir=/usr/share/info
creating cache ./config.cache
Generating configuration file for setserial version 2.17
Release date is January, 2000
checking for gcc... gcc
checking whether the C compiler (gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic )
works... yes
checking whether the C compiler (gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic )
is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for a BSD compatible install... /usr/bin/install -c
checking host system type... x86_64-redhat-linux-gnu
checking build system type... x86_64-redhat-linux-gnu
checking for strip... strip
checking how to run the C preprocessor... gcc -E
checking for asm/ioctls.h... yes
checking for linux/hayesesp.h... no
updating cache ./config.cache
creating ./config.status
creating setserial.8
creating Makefile
+ make
gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -DHAVE_ASM_IOCTLS_H=1  -I.
setserial.c -o setserial
setserial.c:44: warning: missing braces around initializer
setserial.c:44: warning: (near initialization for 'serial_type_tbl[0]')
setserial.c:92: warning: missing braces around initializer
setserial.c:92: warning: (near initialization for 'flag_type_tbl[0]')
setserial.c: In function 'print_multiport':
setserial.c:206: warning: implicit declaration of function 'ioctl'
setserial.c: In function 'get_multiport':
setserial.c:249: warning: implicit declaration of function 'exit'
setserial.c:249: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c: In function 'set_multiport':
setserial.c:271: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:281: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:338: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:342: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c: In function 'print_hayesesp':
setserial.c:362: error: storage size of 'esp' isn't known
setserial.c:362: warning: unused variable 'esp'
setserial.c: In function 'set_hayesesp':
setserial.c:378: error: storage size of 'esp' isn't known
setserial.c:384: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:410: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:378: warning: unused variable 'esp'
setserial.c: In function 'get_serial':
setserial.c:428: warning: implicit declaration of function 'close'
setserial.c: In function 'set_serial':
setserial.c:488: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:494: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:512: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:516: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:520: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:541: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:571: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:575: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:579: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:585: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:592: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:608: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:613: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c: In function 'do_wild_intr':
setserial.c:628: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:632: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:636: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c: In function 'usage':
setserial.c:714: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c: At top level:
setserial.c:718: warning: return type defaults to 'int'
setserial.c: In function 'main':
setserial.c:727: warning: implicit declaration of function 'getopt'
setserial.c:749: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:764: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:770: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:776: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:722: warning: unused variable 'optarg'
make: *** [setserial] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.15351 (%build)
Comment 1 Andreas Thienemann 2006-05-16 06:45:43 EDT

*** This bug has been marked as a duplicate of 191883 ***

Note You need to log in before you can comment on or make changes to this bug.