Bug 191883 - glibc-kernheaders Package won't build in mock
Summary: glibc-kernheaders Package won't build in mock
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc-kernheaders (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 191884 (view as bug list)
Depends On:
Blocks: BuildReqBlocker
TreeView+ depends on / blocked
 
Reported: 2006-05-16 10:43 UTC by Andreas Thienemann
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-16 16:43:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andreas Thienemann 2006-05-16 10:43:02 UTC
The package won't build in mock with the following error on x86_64:

+ ./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu
--target=x86_64-redhat-linux-gnu --program-prefix= --prefix=/usr
--exec-prefix=/usr --bindir=/bin --sbindir=/usr/sbin --sysconfdir=/etc
--datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64
--libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com
--mandir=/usr/share/man --infodir=/usr/share/info
creating cache ./config.cache
Generating configuration file for setserial version 2.17
Release date is January, 2000
checking for gcc... gcc
checking whether the C compiler (gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic )
works... yes
checking whether the C compiler (gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic )
is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for a BSD compatible install... /usr/bin/install -c
checking host system type... x86_64-redhat-linux-gnu
checking build system type... x86_64-redhat-linux-gnu
checking for strip... strip
checking how to run the C preprocessor... gcc -E
checking for asm/ioctls.h... yes
checking for linux/hayesesp.h... no
updating cache ./config.cache
creating ./config.status
creating setserial.8
creating Makefile
+ make
gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -DHAVE_ASM_IOCTLS_H=1  -I.
setserial.c -o setserial
setserial.c:44: warning: missing braces around initializer
setserial.c:44: warning: (near initialization for 'serial_type_tbl[0]')
setserial.c:92: warning: missing braces around initializer
setserial.c:92: warning: (near initialization for 'flag_type_tbl[0]')
setserial.c: In function 'print_multiport':
setserial.c:206: warning: implicit declaration of function 'ioctl'
setserial.c: In function 'get_multiport':
setserial.c:249: warning: implicit declaration of function 'exit'
setserial.c:249: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c: In function 'set_multiport':
setserial.c:271: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:281: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:338: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:342: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c: In function 'print_hayesesp':
setserial.c:362: error: storage size of 'esp' isn't known
setserial.c:362: warning: unused variable 'esp'
setserial.c: In function 'set_hayesesp':
setserial.c:378: error: storage size of 'esp' isn't known
setserial.c:384: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:410: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:378: warning: unused variable 'esp'
setserial.c: In function 'get_serial':
setserial.c:428: warning: implicit declaration of function 'close'
setserial.c: In function 'set_serial':
setserial.c:488: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:494: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:512: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:516: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:520: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:541: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:571: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:575: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:579: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:585: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:592: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:608: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:613: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c: In function 'do_wild_intr':
setserial.c:628: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:632: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:636: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c: In function 'usage':
setserial.c:714: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c: At top level:
setserial.c:718: warning: return type defaults to 'int'
setserial.c: In function 'main':
setserial.c:727: warning: implicit declaration of function 'getopt'
setserial.c:749: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:764: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:770: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:776: warning: incompatible implicit declaration of built-in function
'exit'
setserial.c:722: warning: unused variable 'optarg'
make: *** [setserial] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.15351 (%build)

Comment 1 Andreas Thienemann 2006-05-16 10:45:52 UTC
*** Bug 191884 has been marked as a duplicate of this bug. ***

Comment 2 Tim Waugh 2006-05-16 11:27:45 UTC
Changing component from setserial to glibc-kernheaders.

This build error is caused by <linux/hayesesp.h> not being included in
glibc-kernheaders.

Comment 3 David Woodhouse 2006-05-16 16:43:35 UTC
Should be fixed in glibc-kernheaders-3.0-31, as soon as that makes it through
the build system.

Comment 4 Brian Pepple 2006-05-17 23:38:16 UTC
*** Bug 192006 has been marked as a duplicate of this bug. ***

Comment 5 David Woodhouse 2006-05-18 01:19:41 UTC
Nah, it was some other package that wouldn't build. Probably setserial.


Note You need to log in before you can comment on or make changes to this bug.