Bug 1919562 - Satellite WebUI under settings content tab page getting blank after adding value in "Default HTTP Proxy"
Summary: Satellite WebUI under settings content tab page getting blank after adding va...
Keywords:
Status: CLOSED DUPLICATE of bug 1913290
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Settings
Version: 6.9.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Devendra Singh
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-01-23 17:15 UTC by Ganesh Payelkar
Modified: 2021-01-25 18:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-25 18:09:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ganesh Payelkar 2021-01-23 17:15:06 UTC
Description of problem:

WebUI under setting content page getting blank after adding Default HTTP Proxy

Version-Release number of selected component (if applicable):
satellite-6.9 Beta

How reproducible:
New installation 

Steps to Reproduce:
1.  Create an HTTP Proxy (Go to Infrastructure > Http Proxies)
2.  Go to Administer > Settings > Content tab
3.  Set "Default HTTP Proxy"
4.  As the changed value is not getting refected immediately you need to refresh the page 

Actual results:

After refreshing the page, it is showing blank 

Expected results:

It should show all the values which are under the Content Tab page 

Additional info:

If you remove http_proxy details from the Infrastructure page then this page recover it's values 



==> /var/log/httpd/foreman-ssl_access_ssl.log <==
1.4.8.7 - - [23/Jan/2021:22:26:07 +0530] "PUT /api/settings/198 HTTP/1.1" 200 340 "https://satellite.example.com/settings" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.163 Safari/537.36"

==> /var/log/foreman/production.log <==
2021-01-23T22:26:07 [I|app|09f67666] Started PUT "/api/settings/198" for 127.0.0.1 at 2021-01-23 22:26:07 +0530
2021-01-23T22:26:07 [I|app|09f67666] Processing by Api::V2::SettingsController#update as JSON
2021-01-23T22:26:07 [I|app|09f67666]   Parameters: {"setting"=>{"value"=>"[FILTERED]"}, "apiv"=>"v2", "id"=>"198"}
2021-01-23T22:26:07 [I|aud|09f67666] Setting (198) update event on value --- ''
 09f67666 | , --- proxy1
 09f67666 | ...
2021-01-23T22:26:07 [I|app|09f67666]   Rendering api/v2/settings/update.json.rabl
2021-01-23T22:26:07 [I|app|09f67666]   Rendered api/v2/settings/update.json.rabl (Duration: 22.2ms | Allocations: 12663)
2021-01-23T22:26:07 [I|app|09f67666] Completed 200 OK in 70ms (Views: 23.0ms | ActiveRecord: 11.4ms | Allocations: 25951)

Comment 1 Justin Sherrill 2021-01-25 18:09:51 UTC

*** This bug has been marked as a duplicate of bug 1913290 ***


Note You need to log in before you can comment on or make changes to this bug.