Bug 191970 - mcstrans Missing BuildRequire on libcap-devel
mcstrans Missing BuildRequire on libcap-devel
Status: CLOSED DUPLICATE of bug 191726
Product: Fedora
Classification: Fedora
Component: mcstrans (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-16 12:38 EDT by Andreas Thienemann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-16 12:50:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch, adding the missing buildreqs (456 bytes, patch)
2006-05-16 12:38 EDT, Andreas Thienemann
no flags Details | Diff

  None (edit)
Description Andreas Thienemann 2006-05-16 12:38:14 EDT
Build of mcstrans-0.1.3-1 fails in mock:

+ make 'CFLAGS=-g -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic'
make -C src 
make[1]: Entering directory `/builddir/build/BUILD/mcstrans-0.1.3/src'
cc -g -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -I../include -D_GNU_SOURCE
-D_FILE_OFFSET_BITS=64 -c -o mcstrans.o mcstrans.c
cc -g -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -I../include -D_GNU_SOURCE
-D_FILE_OFFSET_BITS=64 -c -o mcstransd.o mcstransd.c
mcstransd.c:18:28: error: sys/capability.h: No such file or directory
mcstransd.c: In function 'service_request':
mcstransd.c:235: warning: format '%d' expects type 'int', but argument 4 has
type 'ssize_t'
mcstransd.c:235: warning: format '%d' expects type 'int', but argument 5 has
type 'ssize_t'
mcstransd.c:242: warning: format '%d' expects type 'int', but argument 4 has
type 'ssize_t'
mcstransd.c:248: warning: format '%d' expects type 'int', but argument 4 has
type 'ssize_t'
mcstransd.c: In function 'dropprivs':
mcstransd.c:538: error: 'cap_t' undeclared (first use in this function)
mcstransd.c:538: error: (Each undeclared identifier is reported only once
mcstransd.c:538: error: for each function it appears in.)
mcstransd.c:538: error: expected ';' before 'new_caps'
mcstransd.c:540: error: 'new_caps' undeclared (first use in this function)
mcstransd.c:540: warning: implicit declaration of function 'cap_init'
mcstransd.c:542: warning: implicit declaration of function 'cap_set_proc'
mcstransd.c:546: warning: implicit declaration of function 'cap_free'
make[1]: *** [mcstransd.o] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/mcstrans-0.1.3/src'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.24126 (%build)

Attached is a patch, adding the required BuildRequires line.
Comment 1 Andreas Thienemann 2006-05-16 12:38:15 EDT
Created attachment 129228 [details]
Patch, adding the missing buildreqs
Comment 2 Daniel Walsh 2006-05-16 12:50:56 EDT

*** This bug has been marked as a duplicate of 191726 ***

Note You need to log in before you can comment on or make changes to this bug.