Bug 191987 - xorg-x11-server-utils fails to build using mock
xorg-x11-server-utils fails to build using mock
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server-utils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 192004 (view as bug list)
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-16 13:57 EDT by Alexander Täschner
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 05:41:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log of mock (6.24 KB, text/plain)
2006-05-16 13:57 EDT, Alexander Täschner
no flags Details
build.log of sucessful build (136.94 KB, application/octet-stream)
2006-05-16 16:07 EDT, Alexander Täschner
no flags Details

  None (edit)
Description Alexander Täschner 2006-05-16 13:57:51 EDT
Building the SRPM
http://download.fedora.redhat.com/pub/fedora/linux/core/5/source/SRPMS/xorg-x11-server-utils-1.0.1-1.2.src.rpm
using mock fails.

Attached is the build.log.
Comment 1 Alexander Täschner 2006-05-16 13:57:51 EDT
Created attachment 129249 [details]
build.log of mock
Comment 2 Alexander Täschner 2006-05-16 16:07:20 EDT
Created attachment 129266 [details]
build.log of sucessful build

Adding the lines

BuildRequires: xorg-x11-xtrans-devel libXext-devel liblbxutil-devel
BuildRequires: xorg-x11-util-macros libXxf86vm-devel libXrandr-devel
BuildRequires: libXrender-devel libXi-devel libXt-devel libXaw-devel
BuildRequires: libXpm-devel libXxf86misc-devel libXfontcache-devel
BuildRequires: libXp-devel zlib-devel

to xorg-x11-server-utils.spec solves the build problem.

Attached is the build.log.
Comment 3 Brian Pepple 2006-05-17 19:37:37 EDT
*** Bug 192004 has been marked as a duplicate of this bug. ***
Comment 4 Mike A. Harris 2006-05-23 10:40:52 EDT
Changing state to ASSIGNED.
Comment 5 Mike A. Harris 2006-06-06 05:41:09 EDT
Fixed last month and forgot to close bug:

 * Wed May 17 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-5
 - Added a whackload of BuildRequires for bug (#191987)

Note You need to log in before you can comment on or make changes to this bug.