Bug 192004 - MIssing Build Requirements & Problem with configure Macros
MIssing Build Requirements & Problem with configure Macros
Status: CLOSED DUPLICATE of bug 191987
Product: Fedora
Classification: Fedora
Component: xorg-x11-server-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-16 15:23 EDT by Andreas Thienemann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-17 19:37:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch, adding the missing buildreqs (423 bytes, patch)
2006-05-16 15:23 EDT, Andreas Thienemann
no flags Details | Diff

  None (edit)
Description Andreas Thienemann 2006-05-16 15:23:46 EDT
Created attachment 129261 [details]
Patch, adding the missing buildreqs
Comment 1 Andreas Thienemann 2006-05-16 15:23:46 EDT
xorg-x11-server-utils-1.0.1-4 needs a BuildReq for libICE-devel to correctly
build in mock.

However, this still results in the following error:

checking for RGB... yes
./configure: line 3487: XORG_MANPAGE_SECTIONS: command not found
./configure: line 3488: XORG_RELEASE_VERSION: command not found
configure: creating ./config.status
config.status: creating Makefile
config.status: creating config.h
config.status: executing depfiles commands
+ make
make  all-am
make[1]: Entering directory
`/builddir/build/BUILD/xorg-x11-server-utils-1.0.1/rgb-1.0.0'
if gcc -DHAVE_CONFIG_H -I. -I. -I.     -DRGB_DB=\"/usr/share/X11/rgb\" -O2 -g
-pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -MT showrgb-showrgb.o -MD -MP -MF
".deps/showrgb-showrgb.Tpo" -c -o showrgb-showrgb.o `test -f 'showrgb.c' || echo
'./'`showrgb.c; \
then mv -f ".deps/showrgb-showrgb.Tpo" ".deps/showrgb-showrgb.Po"; else rm -f
".deps/showrgb-showrgb.Tpo"; exit 1; fi
gcc  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables   -o showrgb  showrgb-showrgb.o
make[1]: *** No rule to make target `showrgb.@APP_MAN_SUFFIX@', needed by
`all-am'.  Stop.
make[1]: Leaving directory
`/builddir/build/BUILD/xorg-x11-server-utils-1.0.1/rgb-1.0.0'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.62189 (%build)


It seems the XORG_MANPAGE macros are not defined, making configure bawl.


Attached is a patch, fixing the libICE-devel Req.
Comment 2 Brian Pepple 2006-05-17 19:37:23 EDT

*** This bug has been marked as a duplicate of 191987 ***

Note You need to log in before you can comment on or make changes to this bug.