Bug 192006 - /usr/include/linux/if_fddi.h:110: error: field 'gen' has incomplete type
Summary: /usr/include/linux/if_fddi.h:110: error: field 'gen' has incomplete type
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc-kernheaders   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-16 19:27 UTC by Andreas Thienemann
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 05:54:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Build Log (2.44 KB, text/plain)
2006-05-16 19:27 UTC, Andreas Thienemann
no flags Details

Description Andreas Thienemann 2006-05-16 19:27:06 UTC
While rebuilding iptraf in mock, the following error occurs:

make: Entering directory `/builddir/build/BUILD/iptraf-3.0.0/src'
gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -DWORKDIR=\"/var/lib/iptraf\"
-DLOCKDIR=\"/var/lock/iptraf\" -DLOGDIR=\"/var/log/iptraf\"
-DEXECDIR=\"/usr/bin\" -I/usr/include/ncurses -I../support -DVERSION=\"3.0.0\"
-DPLATFORM=\"Linux/i386\"     -c -o iptraf.o iptraf.c
In file included from tcptable.h:25,
                 from iptraf.c:55:
/usr/include/linux/if_fddi.h:110: error: field 'gen' has incomplete type
make: *** [iptraf.o] Error 1
make: Leaving directory `/builddir/build/BUILD/iptraf-3.0.0/src'
error: Bad exit status from /var/tmp/rpm-tmp.52251 (%build)

Buildlog is attached.

Comment 1 Andreas Thienemann 2006-05-16 19:27:06 UTC
Created attachment 129262 [details]
Build Log

Comment 2 David Woodhouse 2006-05-16 22:36:07 UTC
Should be fixed in glibc-kernheaders-3.0-32

Comment 3 Brian Pepple 2006-05-17 23:38:03 UTC

*** This bug has been marked as a duplicate of 191883 ***

Comment 4 Andreas Thienemann 2006-05-18 05:54:26 UTC
Sorry, this is not the same problem.
One is about the missing file for iproute, the other about the missing file for
setserial.

Comment 5 Andreas Thienemann 2006-05-18 05:54:47 UTC
Sorry, this is not the same problem.
One is about the missing file for iproute, the other about the missing file for
setserial.


Note You need to log in before you can comment on or make changes to this bug.