This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 192080 - avahi: omit --enable-compat-libdns_sd
avahi: omit --enable-compat-libdns_sd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-17 09:44 EDT by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-12 13:06:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2006-05-17 09:44:10 EDT
The compat-libdns_sd stuff is limited and incomplete (from
http://0pointer.de/avahi-compat).  In particular, doesn't work with
kdelibs/kdebase (see bug #187822).

I'd like to have the possibility of packaging/using Apple Bonjour
(mDNSResponder), but can't because of avahi's compat lib using the same
library/soname(*).

So, please either omit the --enable-compat-libdns_sd bits, or make those parts
an optional/separate (sub)pkg so it is at least possible to replace with the
real libdns_sd from Apple Bonjour.

(*) OK, I had to hack mDNSResponder to use a real soname (the default Makefiles
are a mess), and happended to collide with avahi's libdns_sd soname.  I could
continue the hackage to simply use a different soname (ie, not libdns_sd.so.1),
but I'd rather not have to do that.
Comment 1 Jason Vas Dias 2006-05-30 19:52:21 EDT
OK, this is now fixed with avahi-0.6.10-1.FC6 - it now provides libdns_sd in
a separate 'avahi-compat-libdns_sd' sub-package, which is optionally installable
(nothing else depends on it). 
BTW, it might be worthwhile trying out the new avahi-compat-libdns_sd package
to see if it now works with kdelibs/kdebase - I'll do some testing as described
in bug #187822 and see if I can resolve the issues with avahi-compat-libdns_sd.
Thanks!
Comment 2 Rex Dieter 2006-05-31 08:12:10 EDT
Don't bother (I don't think it's saveable), I found an avahi-native libkdnssd
implementation for kdelibs that seems to work nicely.  See bug #187820 for details.
Comment 3 Rex Dieter 2006-05-31 08:13:27 EDT
Thanks for splitting the compat lib!  Now we'll at least have the ability/option
to use apples' mDNSResponder.
Comment 4 Fedora Update System 2006-06-07 19:39:57 EDT
avahi-0.6.10-1.FC5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Rex Dieter 2006-06-07 20:55:15 EDT
Thanks!
Comment 6 Lennart Poettering 2007-08-12 13:06:28 EDT
I think this can be closed now.

Note You need to log in before you can comment on or make changes to this bug.