Bug 192088 - LTC23831-Can't install FC5 from veth
LTC23831-Can't install FC5 from veth
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-05-17 11:12 EDT by IBM Bug Proxy
Modified: 2008-03-12 01:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-12 01:54:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2006-05-17 11:12:34 EDT
LTC Owner is: ameet@us.ibm.com
LTC Originator is: shenlinf@cn.ibm.com

Problem description:
vestalp1 was configurated with veth. I booted it from veth by bootp, and then
used veth to install FC5 but it reported "That directory could not be mounted
from the server".

Hardware Environment
    Machine type (p650, x235, SF2, etc.): p5-595
    Cpu type (Power4, Power5, IA-64, etc.): Power5
    Describe any special hardware you think might be relevant to this problem:

Is this reproducible?
    If so, how long does it (did it) take to reproduce it?
    Describe the steps:
    1. config the vestalp1 with veth
    2. setup IPL in SMS
    3. boot from veth by bootp
    4. select veth as Networking Device
    5. Configure TCP/IP
    6. NFS Setup
    7. FC can't mount NFS

Additional information:
1. Networking Device        
         You have multiple network devices on this system.                    
         Which would you like to install through?                             
         eth0 - IBM i/pSeries Virtual Ethernet                                
         eth1 - Intel Corporation 82545GM Gigabit Ethernet Controller         
         eth2 - Intel Corporation 82545GM Gigabit Ethernet Controller         
         eth3 - Intel Corporation 82557/8/9 [Ethernet Pro 100]                
         eth4 - Intel Corporation 82557/8/9 [Ethernet Pro 100]                
         tr0 - IBM 16/4 Token ring UTP/STP controller                         

2. Configure TCP/IP         
         Please enter the IP configuration for this machine. Each             
         item should be entered as an IP address in dotted-decimal            
         notation (for example,                                     
                [ ] Use dynamic IP configuration (BOOTP/DHCP)                 
                   IP address:                      
                   Default gateway (IP):                     
                   Primary nameserver:                     
3. NFS Setup          
           Please enter the following information:                            
               o the name or IP number of your NFS server                     
               o the directory on that server containing                      
                 Fedora Core for your architecture                            
               NFS server name:                
               Fedora Core directory: /distros/rawhide________                

5. Error                       
                        That directory could not be                           
                        mounted from the server.
I was using "fedora-development tree (aka rawhide), snapshot May1".
There are veth(usable) and physical network adapter on vestalp3. When I try to
install FC5, the same problem happends. But after I delete all physical network
adapter, it works. So till now, I am able to install FC5 on systems with only
veth or only physical network card.

For some reason eth4 is now the veth (orginally it was eth0) I booted the system
into U3 and confirmed it.
It's very interesting. If I selected "eth4 - Intel Corporation 82557/8/9
[Ethernet Pro 100]" in FC5 installation, configurated it using the original IP, and it worked!! 

FC5 is installed. ifconfig showes that the active eth is eth4. 
[root@vestalp1 ~]# ifconfig
eth4      Link encap:Ethernet  HWaddr 66:F7:B0:00:10:03  
          inet addr:  Bcast:  Mask:
[root@vestalp1 ~]# ethtool -i eth4
driver: ibmveth

This seems to be the interface naming issue.
during setup the installer load ibmveth first, but during the actual install it
gets loaded after the physical adapter. And since the network configuration file
use normal name convention (eth0, eth1, ....), the installer picks the wrong file.
This could be avoided by using MAC address naming convention or loading the
network modules in the same order.
Comment 1 IBM Bug Proxy 2006-05-30 01:32:21 EDT
----- Additional Comments From shenlinf@cn.ibm.com  2006-05-30 01:34 EDT -------
still not fixed in May 26 version. 
Comment 2 IBM Bug Proxy 2006-06-06 03:17:56 EDT

           What    |Removed                     |Added
            Version|FC5                         |devel

------- Additional Comments From shenlinf@cn.ibm.com  2006-06-06 03:19 EDT -------
I am changing the version to 'devel' to properly reflect that this recreates on
Comment 3 Dave Jones 2006-10-16 15:42:36 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 4 IBM Bug Proxy 2007-02-02 16:35:50 EST

           What    |Removed                     |Added
             Status|OPEN                        |REJECTED
         Resolution|                            |INSUFFICIENT_DATA

------- Additional Comments From ameet@us.ibm.com (prefers email at ameet@austin.ibm.com)  2007-02-02 16:33 EDT -------
We will close this Bugzilla for now.  Please reopen if this is still a problem. 
Comment 5 petrosyan 2008-03-12 01:54:40 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there have not been any
updates to the report since thirty (30) days or more since we
requested additional information, we're assuming the problem
is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested, 
please feel free to reopen the bug report.

Thank you in advance.

Note You need to log in before you can comment on or make changes to this bug.