Bug 192253 - lyx: set default lyxpipe
lyx: set default lyxpipe
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lyx (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-18 12:28 EDT by Edward Grace
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-24 09:55:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Grace 2006-05-18 12:28:30 EDT
Description of problem:

Using pybibliographer I am unable to add a citation to a running instance of
LyX.  It appears that the pipes that should be present are not present.

Version-Release number of selected component (if applicable):


How reproducible:

Always.

See bug 192252

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Zoltan Kota 2006-05-18 18:51:03 EDT
Newer versions of lyx don't seem to create lyxpipe automatically.
You can set it under the menu Tools->Preferences->Paths.
Type /home/yourhome/.lyx/lyxpipe at LyXServer pipe:.
(Maybe it is a feature not a bug?) 
Comment 2 Edward Grace 2006-05-19 04:03:35 EDT
Bingo!  Now works.  I tried playing with that before, but couldn't make it work.
 The secret is entering ~/.lyx/lyxpipe  I was entering ~/.lyx/lyxpipe.in

This is something that I feel needs to be tweaked a little as it should work
"Out of the box".


> (Maybe it is a feature not a bug?) 


I am somewhat sceptical that it's a feature ;-)  

To reiterate in case anyone else has this issue.  Starting from a fresh LyX
configuration (i.e. removing ~/.lyx) the following works for me:

1) Start LyX
2) Under Tools -> Preferences -> Paths enter:
   ~/.lyx/lyxpipe 
   For the option named "LyXServer pipe"
3) Exit LyX
4) Start LyX
5) You should now see two sockets created under ~/.lyx/  They are
~/.lyx/lyxpipe.in and ~/.lyx/lyxpipe.out

6) Start pybibliographer.  It should now work as advertised.


Could someone ensure that the default is set correctly in future versions?  It
really wasn't clear what magic incantations needed to be entered.

Thanks for your prompt response!
Comment 3 Rex Dieter 2006-05-23 15:26:53 EDT
Thanks for the report.

Upon closer inspection, it turns out there's a few other handy defaults that
should (I think anyway) get set.  I'll include these defaults in the next build:
  screen_font_roman "Serif"
  screen_font_sans "Sans"
  screen_font_typewriter "Monospace"
  screen_zoom 100
  serverpipe "~/.lyx/pipe"
Comment 4 Zoltan Kota 2006-05-24 02:26:47 EDT
For serverpipe ~/.lyx/lyxpipe would be better (instead of ~/.lyx/pipe)! 
As I remember that was the default in older versions, and it is the default in
pybliographer.
Comment 5 Rex Dieter 2006-05-24 07:57:20 EDT
OK, will do.
Comment 6 Rex Dieter 2006-05-24 09:55:36 EDT
lyx-1.4.1-7 build queued, should appear soon in a repo near you.

* Wed May 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.1-7
- use serverpipe "~/.lyx/lyxpipe" instead, that was the old default
  and what pybibliographer expects.

* Tue May 23 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.1-6
- set defaults for (see %{_datadir}/lyx/lyxrc.defaults.custom)
  screen_font_roman "Serif"
  screen_font_sans "Sans"
  screen_font_typewriter "Monospace"
  screen_zoom 100
  serverpipe "~/.lyx/pipe"

Note You need to log in before you can comment on or make changes to this bug.