Bug 192264 - rc.sysinit causes rm: cannot remove `/var/run/cups/certs': Is a directory after ugrading to cups-1.2.0
rc.sysinit causes rm: cannot remove `/var/run/cups/certs': Is a directory aft...
Status: CLOSED DUPLICATE of bug 189168
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2006-05-18 13:50 EDT by Peter Bieringer
Modified: 2014-03-16 22:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-18 16:31:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2006-05-18 13:50:55 EDT
Description of problem:
After upgrading to cups-1.2.0, after reboot rc.sysinit claims about a directory
which can't be removed

Version-Release number of selected component (if applicable):

How reproducible:
On every reboot

Steps to Reproduce:
1. Upgrade FC5 system to cups-1.2.0
2. Reboot
Actual results:
Remounting root filesystem in read-write mode:             [  OK  ]
Mounting local filesystems:                                [  OK  ]
Enabling local filesystem quotas:                          [  OK  ]
rm: cannot remove `/var/run/cups/certs': Is a directory
Enabling swap space:                                       [  OK  ]
INIT: Entering runlevel: 3

Expected results:
Not such message

Additional info:

This was caused by a missing entry in code part:

# Clean up /var.  I'd use find, but /usr may not be mounted.
for afile in /var/lock/* /var/run/* ; do
        if [ -d "$afile" ]; then
           case "$afile" in
                */news|*/mon)   ;;
                */sudo)         rm -f $afile/*/* ;;
                */vmware)       rm -rf $afile/*/* ;;
                */samba)        rm -rf $afile/*/* ;;
                */screen)       rm -rf $afile/* ;;
                */cvs)          rm -rf $afile/* ;;
                */dovecot)      rm -f $afile/*/* ;;
                *)              rm -f $afile/* ;;
           rm -f $afile

Looks like this piece of code is not well designed because it need to be
synchronized with other packages, so everytime, a package would create a
subdirectory in /var/run, such issue rises up again...

In comment
this issue was mentioned first
Comment 1 Peter Bieringer 2006-05-18 13:55:32 EDT
Sorry, my comment was not proper, this problem rised up now, because a
sub-sub-directory was created by cups. sub-directories are already handled proper.
Comment 2 Bill Nottingham 2006-05-18 16:31:42 EDT

*** This bug has been marked as a duplicate of 189168 ***

Note You need to log in before you can comment on or make changes to this bug.