Bug 192274 - spinlock cpu recursion bad locking
spinlock cpu recursion bad locking
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-18 14:49 EDT by Need Real Name
Modified: 2015-01-04 17:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-05 08:35:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-05-18 14:49:24 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Need Real Name 2006-05-19 05:04:54 EDT
Sorry, something got wrong when I saved this bug. Here's the bug again:

Hardware configuration:

Intel Pentium 4 3.0 GHz HT CPU
Asrock 775i915P mainboard
768 MB DDR 400 RAM
2x 250 GB WD Caviar SATAII drives in RAID1
Cirrus Logic 1 MB PCI graphics adapter
Initio 940 SCSI adapter

When trying to load initio module, the kernel panics with the following output:

spinlock cpu recursion on CPU#0, swapper/0 (Not tainted) lock: ffff81003f28d860,
.magic dead4ead, .owner: md2_raid1, .owner_cpu: 0

kernel panic - not syncing: bad locking
Comment 2 Need Real Name 2006-05-19 05:07:56 EDT
The kernel version is 2.6.15-1.2054_FC5 SMP 64 bit, also tried kernel 2.6.16-
1.2111_FC5 SMP 64 bit with same result
Comment 3 Dave Jones 2006-09-10 20:26:05 EDT
Please try and reproduce with the latest 2.6.17 based update kernel.
Comment 4 Dave Jones 2006-10-16 17:43:19 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 5 Dave Jones 2006-11-24 17:15:22 EST
This bug has been mass-closed along with all other bugs that
have been in NEEDINFO state for several months.

Due to the large volume of inactive bugs in bugzilla, this
is the only method we have of cleaning out stale bug reports
where the reporter has disappeared.

If you can reproduce this bug after installing all the
current updates, please reopen this bug.

If you are not the reporter, you can add a comment requesting
it be reopened, and someone will get to it asap.

Thank you.
Comment 6 Jon Stanley 2008-02-05 08:35:26 EST
Closing since there was an error in previous mass-close and they remained in
NEEDINFO.

Note You need to log in before you can comment on or make changes to this bug.