Bug 19229 - mkkickstart failed
mkkickstart failed
Status: CLOSED DUPLICATE of bug 18863
Product: Red Hat Linux
Classification: Retired
Component: mkkickstart (Show other bugs)
7.0J
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-17 00:41 EDT by masanari iida
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description masanari iida 2000-10-17 00:41:39 EDT
mkkickstart failed if  "LABEL" is in the /etc/fstab.
LABEL is new feature in RH7, but it still does not support my old mkkickstart.

mkkickstart version mkkickstart-2.3-1
Comment 1 Brock Organ 2000-10-18 15:46:50 EDT
hmmm ... mkkickstart didn't crash for my quick trivial check using an fstab
w/labels, could you attach your fstab ...?

(in fact, mkkickstart ommitted partition information from it's output entirely,
so using that file would force me to manually configure disk partitions in the
kickstart install itself ...)

thanks for your report!
Comment 2 masanari iida 2000-10-18 22:45:12 EDT
Hi

This is my fstab (created by RH install CD)
LABEL=/                 /                       ext2    defaults        1 1
LABEL=/boot             /boot                   ext2    defaults        1 2
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,ro 0 0
/dev/fd0                /mnt/floppy             auto    noauto,owner    0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/pts                devpts  gid=5,mode=620  0 0
/dev/sda6               swap                    swap    defaults        0 0

and  a part of the ks.cfg.

(snip)
zerombr yes
clearpart --linux
part swap --size 128
install
(snip)

and  output of fdisk -l 
Disk /dev/sda: 64 heads, 32 sectors, 8678 cylinders
Units = cylinders of 2048 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sda1   *         1        17     17392   83  Linux
/dev/sda2            18      8678   8868864    5  Extended
/dev/sda5            18      8550   8737776   83  Linux
/dev/sda6          8551      8678    131056   82  Linux swap

I thought the mkkickstart does not understand the "LABEL" part,
so it CAN NOT add the information. (except swap) 
According to your explanation, the new mkkickstart omitted the
partition info from the output.
If so, what I thought bug is not a bug, but a spec.
I hope you will update the mkkickstart online manual to add
all those changes. 

Regards.

Comment 3 Alan Cox 2002-12-14 21:40:09 EST

*** This bug has been marked as a duplicate of 18863 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:47:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.