Bug 1923681 - android-tools: FTBFS in Fedora rawhide/f34
Summary: android-tools: FTBFS in Fedora rawhide/f34
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: android-tools
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ivan Afonichev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1958912 (view as bug list)
Depends On:
Blocks: F34FTBFS
TreeView+ depends on / blocked
 
Reported: 2021-02-01 17:25 UTC by Fedora Release Engineering
Modified: 2021-08-12 01:06 UTC (History)
10 users (show)

Fixed In Version: android-tools-31.0.2-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-12 01:06:10 UTC
Type: ---


Attachments (Terms of Use)
build.log (32.00 KB, text/plain)
2021-02-01 17:25 UTC, Fedora Release Engineering
no flags Details
root.log (32.00 KB, text/plain)
2021-02-01 17:25 UTC, Fedora Release Engineering
no flags Details
state.log (1.07 KB, text/plain)
2021-02-01 17:25 UTC, Fedora Release Engineering
no flags Details
Patch for https://src.fedoraproject.org/rpms/android-tools/tree/f34 (136.55 KB, patch)
2021-07-15 14:13 UTC, Brian J. Murrell
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Github nmeum android-tools issues 16 0 None None None 2021-08-01 16:29:58 UTC

Description Fedora Release Engineering 2021-02-01 17:25:23 UTC
android-tools failed to build from source in Fedora rawhide/f34

https://koji.fedoraproject.org/koji/taskinfo?taskID=60913735


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
Please fix android-tools at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
android-tools will be orphaned. Before branching of Fedora 35,
android-tools will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Fedora Release Engineering 2021-02-01 17:25:25 UTC
Created attachment 1753972 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2021-02-01 17:25:26 UTC
Created attachment 1753973 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2021-02-01 17:25:27 UTC
Created attachment 1753974 [details]
state.log

Comment 4 Ben Cotton 2021-02-09 16:00:02 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 5 Leon Fauster 2021-02-13 18:58:46 UTC
It seems that it does not build with clang-11 ?!

Comment 6 Ivan Afonichev 2021-02-13 19:33:13 UTC
Initial f33 build succeeded https://koji.fedoraproject.org/koji/buildinfo?buildID=1548173
(Not sure which clang has been used there)

But later builds that are using clang 11.0.0-2.fc33 fail.

Not sure what has changed, looks like some "hidden" processing behaviour. I'am trying to prepare latest upstream version of android tools to be build on fedora but not sure if it will be finished in time.

If you have any ideas how to fix current version issue, contributions are much appreciated.

Comment 7 Leon Fauster 2021-02-13 20:38:08 UTC
(In reply to Ivan Afonichev from comment #6)
> Initial f33 build succeeded
> https://koji.fedoraproject.org/koji/buildinfo?buildID=1548173
> (Not sure which clang has been used there)
> 
> But later builds that are using clang 11.0.0-2.fc33 fail.


The working version seems to be clang 10.0.0-7.fc33

https://kojipkgs.fedoraproject.org//packages/android-tools/20180828gitc7815d675/8.fc33/data/logs/x86_64/root.log


 
> Not sure what has changed, looks like some "hidden" processing behaviour.
> I'am trying to prepare latest upstream version of android tools to be build
> on fedora but not sure if it will be finished in time.
> 
> If you have any ideas how to fix current version issue, contributions are
> much appreciated.

I stumbled across it myself. Next distros will use clang 11:

11.1.0-0.4.rc2.fc34
11.0.0-1.module_el8.4.0+587+5187cac0
11.0.0-2.fc33

clang's linker seems to have a problem 

https://download.copr.fedorainfracloud.org/results/ne0l/test-playground/fedora-rawhide-x86_64/01964362-android-tools/builder-live.log.gz
https://download.copr.fedorainfracloud.org/results/ne0l/test-playground/centos-stream-x86_64/01964362-android-tools/builder-live.log.gz
https://download.copr.fedorainfracloud.org/results/ne0l/test-playground/fedora-33-x86_64/01964362-android-tools/builder-live.log.gz

Comment 8 Christian Stadelmann 2021-06-03 12:11:52 UTC
*** Bug 1958912 has been marked as a duplicate of this bug. ***

Comment 9 Pranav 2021-06-12 04:12:36 UTC
I have a situation in Fedora 34 where I cannot connect Oneplus 5. All details are over here: https://ask.fedoraproject.org/t/failed-to-use-adb-command-in-oneplus-5-through-fedora-34/14881/17

Someone mentioned that my situation might be related to this bug report. But, is it!? (I don't think so.)

Comment 10 Brian J. Murrell 2021-06-25 20:06:00 UTC
I suppose this bug is why android-tools *regressed* from android-tools-30.0.5p1-1.fc33 in F33 to android-tools-20180828gitc7815d675-8.fc33 in F34!

Is anything being done to rectify this?  It really sucks having to back to an older adb that does not support wireless USB debugging.

Comment 11 Brian J. Murrell 2021-06-25 20:09:54 UTC
Isn't the issue blocking all of this fixed in https://github.com/nmeum/android-tools/commit/df7bb55525aa93831874b2be8d7b21a5101d1466?

Comment 12 Brian J. Murrell 2021-07-14 21:52:14 UTC
Hello?  Could somebody that knows, please respond to comment #11?

If that is indeed the upstream fix, can we have a new build of android-tools?

Comment 13 Ivan Afonichev 2021-07-14 22:08:36 UTC
Yes it is fixed in https://github.com/nmeum/android-tools/commit/df7bb55525aa93831874b2be8d7b21a5101d1466? but that change is not yet released.
Latest release is 31.0.0p1 @nmeum released this on 14 Apr

Comment 14 Brian J. Murrell 2021-07-15 14:13:19 UTC
Created attachment 1801894 [details]
Patch for https://src.fedoraproject.org/rpms/android-tools/tree/f34

Indeed.  But those patches do successfully apply to 31.0.0p1 and are committed upstream, so why can a new release of this package, based on 31.0.0p1 with the upstream patches applied not be made?  It builds and works.

Please see the attached patch as it applies to https://src.fedoraproject.org/rpms/android-tools/tree/f34.  I tried to create a PR there but it seems that "regular joe"s cannot create PRs there.

Comment 15 Christian Stadelmann 2021-08-01 16:29:59 UTC
Upstream has released 31.0.2 [1] with a fix for this bug (see upstream #16 [2]). Can you please update android-tools to the latest upstream version?

[1] https://github.com/nmeum/android-tools/releases
[2] https://github.com/nmeum/android-tools/issues/16

Comment 16 Fedora Update System 2021-08-03 23:02:20 UTC
FEDORA-2021-3a6e9d852b has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-3a6e9d852b

Comment 17 Fedora Update System 2021-08-04 03:43:04 UTC
FEDORA-2021-3a6e9d852b has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-3a6e9d852b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-3a6e9d852b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Fedora Update System 2021-08-12 01:06:10 UTC
FEDORA-2021-3a6e9d852b has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.