Bug 1924785 - Cinder volume provisioning crashes on nil cloud provider
Summary: Cinder volume provisioning crashes on nil cloud provider
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.6.z
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 4.6.z
Assignee: Mike Fedosin
QA Contact: weiwei jiang
URL:
Whiteboard:
: 1938188 1946672 (view as bug list)
Depends On: 1894645
Blocks: 1928978
TreeView+ depends on / blocked
 
Reported: 2021-02-03 15:43 UTC by OpenShift BugZilla Robot
Modified: 2021-04-09 15:13 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-02 04:48:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kubernetes pull 548 0 None open [release-4.6] Bug 1924785: UPSTREAM: 89885: SQUASH: Fix cinder crash 2021-02-17 09:32:58 UTC
Red Hat Product Errata RHBA-2021:0634 0 None None None 2021-03-02 04:48:28 UTC

Comment 3 weiwei jiang 2021-02-22 06:56:39 UTC
Verified with 4.6.0-0.nightly-2021-02-20-055459.

$ oc get clusterversion 
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2021-02-20-055459   True        False         39m     Cluster version is 4.6.0-0.nightly-2021-02-20-055459

$ oc -n openshift-kube-controller-manager logs kube-controller-manager-wj46ios222aa-x5nr9-master-2 |grep -i openstack.go
E0222 06:20:00.773474       1 openstack.go:284] cannot get secret openstack-credentials in namespace kube-system. error: "secret \"openstack-credentials\" not found"
E0222 06:20:02.348456       1 openstack.go:284] cannot get secret openstack-credentials in namespace kube-system. error: "secret \"openstack-credentials\" not found"
I0222 06:20:13.356086       1 openstack.go:301] OpenStack cloud provider was initialized using data from the secret.

$ oc get sc
NAME                 PROVISIONER                RECLAIMPOLICY   VOLUMEBINDINGMODE      ALLOWVOLUMEEXPANSION   AGE
csi-manila-ceph      manila.csi.openstack.org   Delete          Immediate              false                  67m
standard (default)   kubernetes.io/cinder       Delete          WaitForFirstConsumer   true                   69m

Comment 5 errata-xmlrpc 2021-03-02 04:48:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.19 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0634

Comment 7 Martin André 2021-04-07 12:54:14 UTC
*** Bug 1946672 has been marked as a duplicate of this bug. ***

Comment 8 Maciej Szulik 2021-04-09 15:13:43 UTC
*** Bug 1938188 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.