Bug 1928978 - Cinder volume provisioning crashes on nil cloud provider
Summary: Cinder volume provisioning crashes on nil cloud provider
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.5
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 4.5.z
Assignee: Eric Duen
QA Contact: David Sanz
URL:
Whiteboard:
Depends On: 1924785
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-15 22:33 UTC by Mike Fedosin
Modified: 2021-03-11 06:55 UTC (History)
22 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1894645
Environment:
Last Closed: 2021-03-11 06:55:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 25899 0 None open [release-4.5] Bug 1928978: UPSTREAM: 89885: SQUASH: Fix cinder crash 2021-02-22 08:35:26 UTC
Red Hat Product Errata RHBA-2021:0714 0 None None None 2021-03-11 06:55:35 UTC

Comment 1 Emanuel Rolon 2021-02-23 18:52:54 UTC
Hello team, i hope this message finds you well.

Do we have any update in the progress of this backport?

Thanks a lot.

Comment 5 weiwei jiang 2021-03-03 12:59:35 UTC
Checked with 4.5.0-0.nightly-2021-03-03-053631 and can not reproduce this, move to verified.

$ oc get clusterversion 
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2021-03-03-053631   True        False         104m    Cluster version is 4.5.0-0.nightly-2021-03-03-053631


$ oc -n openshift-kube-controller-manager logs kube-controller-manager-wj45ios303kr-9kxxw-master-1 |grep -i openstack.go
E0303 10:56:46.758971       1 openstack.go:284] cannot get secret openstack-credentials in namespace kube-system. error: "secret \"openstack-credentials\" not found"
I0303 10:56:47.631712       1 openstack.go:301] OpenStack cloud provider was initialized using data from the secret.

$ oc get co storage 
NAME      VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
storage   4.5.0-0.nightly-2021-03-03-053631   True        False         False      128m

$ oc get sc 
NAME                 PROVISIONER            RECLAIMPOLICY   VOLUMEBINDINGMODE      ALLOWVOLUMEEXPANSION   AGE
standard (default)   kubernetes.io/cinder   Delete          WaitForFirstConsumer   true                   128m

Comment 11 errata-xmlrpc 2021-03-11 06:55:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.34 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0714


Note You need to log in before you can comment on or make changes to this bug.