Bug 192513 - ICE (Segmentation fault) building 3ddesktop source
ICE (Segmentation fault) building 3ddesktop source
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 192801 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-20 03:23 EDT by Hugo Cisneiros
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.1.0-19.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-22 04:03:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hugo Cisneiros 2006-05-20 03:23:18 EDT
Description of problem:

The gcc's c++ component isn't compiling the 3ddesktop source. Searching about 
this problem, I found out that it may be a bug in gcc itself, as these URLs 
shows (and this report is based on them):

http://gcc.gnu.org/ml/gcc-bugs/2006-03/msg01927.html
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=26757

It only happens with GCC 4.1 on FC5. GCC 4.0 on FC4 is fine. I'm needing this 
to compile 3ddesktop for inclusion on Extras, so any feedback on this would be 
great.

The following error occurs:

if g++ -DHAVE_CONFIG_H -I. -I. -I.    -Wall -O3 -DQT_CLEAN_NAMESPACE 
-DSHAREDIR=\"/usr/local/share/3ddesktop\" -DSYSCONFDIR=\"/usr/local/etc\"   -g 
-O2  -MT 3ddeskd.o -MD -MP -MF ".deps/3ddeskd.Tpo" -c -o 3ddeskd.o 
3ddeskd.cpp; \
then mv -f ".deps/3ddeskd.Tpo" ".deps/3ddeskd.Po"; else rm -f 
".deps/3ddeskd.Tpo"; exit 1; fi
3ddeskd.cpp: In function ‘void draw_digit(int, float, float)’:
3ddeskd.cpp:634: internal compiler error: Segmentation fault

Version-Release number of selected component (if applicable):

gcc-4.1.0-3
gcc-c++-4.1.0-3

How reproducible:

Steps to Reproduce:
1. Grab the 3ddesktop source at http://3ddesktop.sourceforge.net
2. Run ./configure, satisfying all dependencies
3. Run make and see the segmentation fault error
Comment 1 Jakub Jelinek 2006-05-22 04:03:40 EDT
Already fixed in gcc-4.1.0-19.fc5, currently in FC5 testing updates.
Comment 2 Jakub Jelinek 2006-05-23 05:04:55 EDT
*** Bug 192801 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.