Bug 192801 - internal compiler error: Segmentation fault
internal compiler error: Segmentation fault
Status: CLOSED DUPLICATE of bug 192513
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-23 03:44 EDT by Graham
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 05:04:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source stored into /tmp/ccw3BERk.out file, please attach this to your bugreport. (1.15 MB, application/octet-stream)
2006-05-23 03:44 EDT, Graham
no flags Details

  None (edit)
Description Graham 2006-05-23 03:44:20 EDT
Description of problem:
[gbnorthg@GBDEVUNXD10 3ddesktop-0.2.9]$ make clean all
test -z "3ddesk 3ddeskd" || rm -f 3ddesk 3ddeskd
rm -f *.o
make  all-am
make[1]: Entering directory `/home/gbnorthg/Desktop/3ddesktop-0.2.9'
if g++ -DHAVE_CONFIG_H -I. -I. -I.    -Wall -O3 -DQT_CLEAN_NAMESPACE
-DSHAREDIR=\"/usr/local/share/3ddesktop\" -DSYSCONFDIR=\"/usr/local/etc\"   -g
-O2  -MT 3ddesk.o -MD -MP -MF ".deps/3ddesk.Tpo" -c -o 3ddesk.o 3ddesk.cpp; \
then mv -f ".deps/3ddesk.Tpo" ".deps/3ddesk.Po"; else rm -f ".deps/3ddesk.Tpo";
exit 1; fi
g++ -Wall -O3 -DQT_CLEAN_NAMESPACE -DSHAREDIR=\"/usr/local/share/3ddesktop\"
-DSYSCONFDIR=\"/usr/local/etc\"   -g -O2    -o 3ddesk  3ddesk.o  -lm -lXxf86vm
-lXext   -lSM -lICE -lSM -lICE 
if g++ -DHAVE_CONFIG_H -I. -I. -I.    -Wall -O3 -DQT_CLEAN_NAMESPACE
-DSHAREDIR=\"/usr/local/share/3ddesktop\" -DSYSCONFDIR=\"/usr/local/etc\"   -g
-O2  -MT 3ddeskd.o -MD -MP -MF ".deps/3ddeskd.Tpo" -c -o 3ddeskd.o 3ddeskd.cpp; \
then mv -f ".deps/3ddeskd.Tpo" ".deps/3ddeskd.Po"; else rm -f
".deps/3ddeskd.Tpo"; exit 1; fi
3ddeskd.cpp: In function ‘void draw_digit(int, float, float)’:
3ddeskd.cpp:634: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccw3BERk.out file, please attach this to
your bugreport.
make[1]: *** [3ddeskd.o] Error 1
make[1]: Leaving directory `/home/gbnorthg/Desktop/3ddesktop-0.2.9'
make: *** [all] Error 2


Version-Release number of selected component (if applicable):
[gbnorthg@GBDEVUNXD10 3ddesktop-0.2.9]$ gcc --version
gcc (GCC) 4.1.0 20060304 (Red Hat 4.1.0-3)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

[gbnorthg@GBDEVUNXD10 3ddesktop-0.2.9]$ gcc32 --version
gcc32 (GCC) 3.2.3 20030502 (Red Hat Linux 3.2.3-55.fc5)
Copyright (C) 2002 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

How reproducible:
very

Steps to Reproduce:
0. Download 3ddesktop source from sourceforge
1. ./configure or ./configure CC=gcc32
2. make clean all
3. fail in 3ddeskd.cpp line 634: internal compiler error: Segmentation fault
  
Actual results:
Build OK

Expected results:
Failed due to seg fault

Additional info:
Recent full yum upgrade (COP 22/05/06)
Comment 1 Graham 2006-05-23 03:44:21 EDT
Created attachment 129845 [details]
Preprocessed source stored into /tmp/ccw3BERk.out file, please attach this to your bugreport.
Comment 2 Jakub Jelinek 2006-05-23 05:04:53 EDT

*** This bug has been marked as a duplicate of 192513 ***

Note You need to log in before you can comment on or make changes to this bug.