Bug 192541 - vfat filesystem ignores the iocharset option
vfat filesystem ignores the iocharset option
Status: CLOSED DUPLICATE of bug 181963
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-05-20 06:11 EDT by Andrew Zabolotny
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-21 13:27:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
A tiny VFAT image with files/directories using Cyrillic (804 bytes, application/x-bzip2)
2006-05-20 06:11 EDT, Andrew Zabolotny
no flags Details

  None (edit)
Description Andrew Zabolotny 2006-05-20 06:11:24 EDT
Description of problem:

The vfat module ignores the "iocharset" option and always assumes that UTF-8 is
used as system charset. Basically this means that any files/directories are
unusable if your system charset differs from UTF-8. The "codepage" option works
for short filenames (without long Unicode equivalents) which is correct.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Unpack the attached file vfat-img.bz2. This is a tiny VFAT image made
manually with some files/directories using codepage 866 (cyrillic).
2. Mount it like this:
   mkdir tmp
   mount vfat-img /mnt/tmp -o loop,codepage=866,iocharset=cp1251
3. Execute:
   LANG=ru_RU.KOI8-R ls -la /tmp >list.txt
4. Compare resulting list.txt with the file tmp/file-list.txt.
Actual results:

The file names in list.txt are in UTF-8, while the file names in
tmp/file-list.txt are in KOI8-R.

Expected results:

The file list in both lists are in the same encoding.
Comment 1 Andrew Zabolotny 2006-05-20 06:11:24 EDT
Created attachment 129722 [details]
A tiny VFAT image with files/directories using Cyrillic
Comment 2 Andrew Zabolotny 2006-05-21 13:27:17 EDT
Actually after looking at kernel SRPM it seems that this bug is due to the
incorrectly resolved bug #181963.

Closing this bug.

*** This bug has been marked as a duplicate of 181963 ***

Note You need to log in before you can comment on or make changes to this bug.