Bug 192587 - scim update causes kmail, knode to crash (SEGV) at startup
scim update causes kmail, knode to crash (SEGV) at startup
Status: CLOSED DUPLICATE of bug 192788
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-21 05:55 EDT by Travers Carter
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-25 08:31:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrack for i386 machne is attached (2.48 KB, text/plain)
2006-05-22 04:01 EDT, A S Alam
no flags Details

  None (edit)
Description Travers Carter 2006-05-21 05:55:07 EDT
Description of problem:
Latest scim (or libstdc++so7?) updates cause kmail, knode and kaffeine to 
crash at startup.  Other apps may also be affected but not all KDE apps crash, 
for example kate, konqueror and kcontrol are all unaffected,

Version-Release number of selected component (if applicable):
scim-1.4.4-9.2.fc5
libstdc++so7-4.2.0-0.3.20060428.fc5.1
kdepim-3.5.2-0.4.fc5

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to scim-1.4.4-9.2.fc5, libstdc++so7-4.2.0-0.3.20060428
2. Start kmail, knode or kaffeine (kaffeine rpm from livna)
  
Actual results:
Application crashes at startup:
$ gdb knode
(gdb) set follow-fork-mode child
(gdb) run
Starting program: /usr/bin/knode
[Thread debugging using libthread_db enabled]
[New Thread 46912496361792 (LWP 15325)]
Attaching after fork to child process 15329.
[New LWP 15329]

Program received signal SIGSEGV, Segmentation fault.
[Switching to LWP 15329]
0x00002aaaae519d52 in scim::QScimInputContext::metaObject () 
from /usr/lib64/qt-3.3/plugins/inputmethods/libqscim.so
(gdb) bt
#0  0x00002aaaae519d52 in scim::QScimInputContext::metaObject () 
from /usr/lib64/qt-3.3/plugins/inputmethods/libqscim.so
#1  0x0000000000000000 in ?? ()

Expected results:
Applications shouldn't crash

Additional info:
Reverting to scim-1.4.4-9.1.fc5 and libstdc++so7-4.2.0-0.3.20060203 makes the 
problem go away with the same kdepim (3.5.2-0.4.fc5).
Comment 1 A S Alam 2006-05-22 04:01:00 EDT
Created attachment 129790 [details]
backtrack for i386 machne is attached
Comment 2 A S Alam 2006-05-22 04:02:51 EDT
During quit of the application on i386 machine, it is showing Signal 11 (SIGSEGV).
Back Track log file is attached
Comment 3 Travers Carter 2006-05-25 08:30:20 EDT
Seems to be the same as Bug #192788, removing scim-qtimm resolves the crashes 
for me.
Comment 4 Travers Carter 2006-05-25 08:31:09 EDT

*** This bug has been marked as a duplicate of 192788 ***

Note You need to log in before you can comment on or make changes to this bug.