Bug 192788 - KDE/QT apps crash after update
KDE/QT apps crash after update
Status: CLOSED DUPLICATE of bug 192471
Product: Fedora
Classification: Fedora
Component: scim-qtimm (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jens Petersen
: Reopened
: 192587 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-22 21:29 EDT by Ang Houfu
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 04:54:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bz2 compressed output from "strace -o kdvi.strace.txt kdvi" (58.27 KB, application/x-bzip2)
2006-05-22 22:44 EDT, Michael Lin
no flags Details
BackTrack for kate crash (3.54 KB, text/plain)
2006-06-02 03:04 EDT, A S Alam
no flags Details

  None (edit)
Description Ang Houfu 2006-05-22 21:29:59 EDT
Description of problem:
QT and KDE apps crash and caused SISGSEV straight after opening, even though
logging in to KDE session is normal. Apps also crash when launched from GNOME.
Can't produce useful backtraces, but this happened after updating my system
since May 20. List of Apps that crash include amaroK, lyx, Konqueror, k3b.

Version-Release number of selected component (if applicable):
qt-3.3.5-13 (i386, x86_64)
kdebase-3.5.2-0.4.fc5 (both arch)
kdelibs-3.5.2-0.2.fc5 (both arch)
amarok-1.4-0.12.beta3.fc5
lyx-1.4.1-4.fc5
k3b-0.12.14-0.FC5.2
kdemultimedia-3.5.2-0.1.fc5
kdenetwork-3.5.2-0.1.fc5
kdegraphics-3.5.2-0.1.fc5

How reproducible:
All KDE applications expected to crash whenever opened.

Steps to Reproduce:
1. Log in to system
2. Open KDE/QT app
3. After a few seconds, Crash
  
Actual results:
Application crashes

Expected results:
Application to run smoothly

Additional info:
Just did a clean install of FC5 where everything worked as per normal until
doing a massive update. After that, the problem is reproduced.
Comment 1 Gian Paolo Mureddu 2006-05-22 22:17:02 EDT
Just to corroborate this, here is the backtrace of k3b (not too useful, but
points out the culprit library:

K3B bactrace, as reported by KCrash handler:
(no debugging symbols found)
Using host libthread_db library "/lib64/libthread_db.so.1".
(no debugging symbols found)
...
[Thread debugging using libthread_db enabled]
[New Thread 47457266815136 (LWP 18778)]
(no debugging symbols found)
...
[KCrash handler]
#5  0x00002b298621dd52 in scim::QScimInputContext::metaObject ()
   from /usr/lib64/qt-3.3/plugins/inputmethods/libqscim.so
#6  0x0000000000000000 in ?? ()

amaroK produces the same. Running the above mentionned packages on x86_64 Core 5
Comment 2 Michael Lin 2006-05-22 22:44:33 EDT
Created attachment 129838 [details]
bz2 compressed output from "strace -o kdvi.strace.txt kdvi"
Comment 3 Michael Lin 2006-05-22 22:51:10 EDT
Please add i686 to the list of hardware affected.  I also have kde/qt
applications crashing/SIGSEGV 11-ing after the last week's round of FC5 updates
(from yum, with just core, updates, extras enabled).  The applications will open
and run, but immediately crash upon closing.  This occurs both logged into GNOME
as well as KDE.  

Here is a typical backtrace (this one right after closing kdvi, but I get
exactly the same backtrace with k3b, kate, kppp, etc.)

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its symbols.
(no debugging symbols found) <== many times
[Thread debugging using libthread_db enabled]
[New Thread -1208153408 (LWP 5288)]
(no debugging symbols found) <== many times
[KCrash handler]
#6  0x009b898e in exit () from /lib/libc.so.6
#7  0x009a372c in __libc_start_main () from /lib/libc.so.6
#8  0x080501c1 in ?? ()

I attached above the output of "strace -o kdvi.strace.txt kdvi"
Comment 4 Ngo Than 2006-05-23 03:44:32 EDT
it seems a bug in scim-qtimm, SCIM input method module for Qt. Could you please
remove this package scim-qtimm (rpm -e scim-qtimm) and try again? Thanks
Comment 5 Gian Paolo Mureddu 2006-05-23 05:07:52 EDT
Indeed, that worked. AmaroK starts now, and presumably so will K3B... (checking
-\|/-) Yes it does, so I assume the other apps will also work. Thanks for the
tip, and one question: Why was scim-qtimm needed? Will it be marked as a dep for
future updates?

Thanks!
Comment 6 Michael Lin 2006-05-23 06:32:43 EDT
Removing scim-qtimm also fixed the problem on i686 as well.
Comment 7 Michael Lin 2006-05-23 06:39:33 EDT
One odd thing is I've had the same version of scim-qtimm-0.9.4-2.1.1 since
installing FC5 from disk; it hasn't changed.  And yet the problems with kde/qt
applications didn't start until ~1 week ago.

Comment 8 Ang Houfu 2006-05-23 07:02:14 EDT
Hi, as expected removing scim qtimm solved the problem. Lyx and amaroK now
running. Thanks!
Comment 9 Travers Carter 2006-05-25 08:31:22 EDT
*** Bug 192587 has been marked as a duplicate of this bug. ***
Comment 10 Jens Petersen 2006-05-31 04:51:38 EDT
This is related to the fact that scim-qtimm can't build with libstdc++so7.
This problem is expected to go away in FC6.  See bug 182177 for more details.
(It was probably just luck that scim-qtimm wasn't crashing apps previously.)
Comment 11 Jens Petersen 2006-05-31 04:54:53 EDT
*** Bug 189209 has been marked as a duplicate of this bug. ***
Comment 12 Jens Petersen 2006-05-31 05:06:10 EDT
*** Bug 192471 has been marked as a duplicate of this bug. ***
Comment 13 A S Alam 2006-05-31 05:24:30 EDT
Problem till exist at Devel version.
Comment 14 A S Alam 2006-06-02 03:04:21 EDT
Created attachment 130382 [details]
BackTrack for kate crash
Comment 15 Jens Petersen 2006-06-06 04:52:11 EDT
The rawhide kate crash is bug 193855.
Comment 16 Jens Petersen 2006-06-06 04:54:52 EDT

*** This bug has been marked as a duplicate of 192471 ***
Comment 17 Jens Petersen 2006-06-26 22:05:59 EDT
(In reply to comment #7)
> One odd thing is I've had the same version of scim-qtimm-0.9.4-2.1.1 since
> installing FC5 from disk; it hasn't changed.  And yet the problems with kde/qt
> applications didn't start until ~1 week ago.

It was probably triggered by the change of libstdc++so7 version somehow.

Note You need to log in before you can comment on or make changes to this bug.