Bug 19260 - kernel fails compilation for NON-SMP due to undefined symbols
Summary: kernel fails compilation for NON-SMP due to undefined symbols
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 19259 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-17 15:07 UTC by Bassem Jamaleddine
Modified: 2007-04-18 16:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-20 17:46:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bassem Jamaleddine 2000-10-17 15:07:51 UTC
The smp.h  header file defines symbols used during the 'make of the
kernel', if
not defined the Makefile exit due to an error. To remedy the problem, 
either define
the __SMP__ by passing it on the command line, or edit the smp.h file and
delete
the '#ifdef  __SMP__'  with its #endif.

Comment 1 Alan Cox 2000-10-17 15:45:44 UTC
*** Bug 19259 has been marked as a duplicate of this bug. ***

Comment 2 Arjan van de Ven 2000-10-17 16:38:51 UTC
Can you name some of the symbols, this souns like the famous "make mrproper"
bug.
(dupe of 18912 in that case)

Comment 3 Robert Dowling 2000-12-04 23:32:03 UTC
If it's what I had trouble with, the symbol "smp_num_cpus" is
undefined when kernel_stat.h is being parsed.  Removing the #define as
suggested gets me further, but then it blows up on line 26 of smp.h
when compiling i386_ksyms.c.  I finally gave up and did "make mrproper"
and life was good.

Comment 4 Need Real Name 2000-12-20 17:46:44 UTC
See also Bug #20677

Comment 5 Bill Nottingham 2000-12-20 19:48:42 UTC
You need to run 'make mrproper' first.


Note You need to log in before you can comment on or make changes to this bug.