Bug 1926225 - python-rnc2rng fails to build with Python 3.10: ImportError: cannot import name 'MutableMapping' from 'collections'
Summary: python-rnc2rng fails to build with Python 3.10: ImportError: cannot import na...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-rnc2rng
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Igor Raits
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1969119 (view as bug list)
Depends On: 1926231
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-02-08 13:21 UTC by Tomáš Hrnčiar
Modified: 2021-06-13 09:43 UTC (History)
4 users (show)

Fixed In Version: python-rnc2rng-2.6.1-10.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-13 09:43:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-02-08 13:21:00 UTC
python-rnc2rng fails to build with Python 3.10.0a5.

Traceback (most recent call last):
  File "/builddir/build/BUILD/rnc2rng-2.6.1/test.py", line 1, in <module>
    import rnc2rng
  File "/builddir/build/BUILD/rnc2rng-2.6.1/rnc2rng/__init__.py", line 1, in <module>
    from . import parser, serializer
  File "/builddir/build/BUILD/rnc2rng-2.6.1/rnc2rng/parser.py", line 1, in <module>
    import rply, sys, os
  File "/usr/lib/python3.10/site-packages/rply/__init__.py", line 3, in <module>
    from rply.parsergenerator import ParserGenerator
  File "/usr/lib/python3.10/site-packages/rply/parsergenerator.py", line 12, in <module>
    from rply.grammar import Grammar
  File "/usr/lib/python3.10/site-packages/rply/grammar.py", line 2, in <module>
    from rply.utils import iteritems
  File "/usr/lib/python3.10/site-packages/rply/utils.py", line 2, in <module>
    from collections import MutableMapping
ImportError: cannot import name 'MutableMapping' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)

bpo-37324: Remove deprecated aliases to Collections Abstract Base Classes
from the collections module.

https://docs.python.org/3.10/whatsnew/changelog.html#python-3-10-0-alpha-5

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01952446-python-rnc2rng/

For all our attempts to build python-rnc2rng with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-rnc2rng/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2021-02-09 16:07:18 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 2 Miro Hrončok 2021-06-04 20:16:03 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 3 Miro Hrončok 2021-06-07 23:00:23 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 4 Miro Hrončok 2021-06-08 11:32:20 UTC
*** Bug 1969119 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.