Bug 1926231 - python-rply fails to build with Python 3.10: ImportError: cannot import name 'MutableMapping' from 'collections'
Summary: python-rply fails to build with Python 3.10: ImportError: cannot import name ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-rply
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Igor Raits
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1969120 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10 1926207 1926225
TreeView+ depends on / blocked
 
Reported: 2021-02-08 13:22 UTC by Tomáš Hrnčiar
Modified: 2021-06-13 09:42 UTC (History)
4 users (show)

Fixed In Version: python-rply-0.7.8-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-13 09:42:54 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-02-08 13:22:37 UTC
python-rply fails to build with Python 3.10.0a5.

==================================== ERRORS ====================================
_____________________ ERROR collecting tests/test_both.py ______________________
ImportError while importing test module '/builddir/build/BUILD/rply-0.7.6/tests/test_both.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
tests/test_both.py:3: in <module>
    from rply import LexerGenerator, ParserGenerator
rply/__init__.py:3: in <module>
    from rply.parsergenerator import ParserGenerator
rply/parsergenerator.py:12: in <module>
    from rply.grammar import Grammar
rply/grammar.py:2: in <module>
    from rply.utils import iteritems
rply/utils.py:2: in <module>
    from collections import MutableMapping
E   ImportError: cannot import name 'MutableMapping' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
_____________________ ERROR collecting tests/test_lexer.py _____________________
ImportError while importing test module '/builddir/build/BUILD/rply-0.7.6/tests/test_lexer.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
tests/test_lexer.py:5: in <module>
    from rply import LexerGenerator
rply/__init__.py:3: in <module>
    from rply.parsergenerator import ParserGenerator
rply/parsergenerator.py:12: in <module>
    from rply.grammar import Grammar
rply/grammar.py:2: in <module>
    from rply.utils import iteritems
rply/utils.py:2: in <module>
    from collections import MutableMapping
E   ImportError: cannot import name 'MutableMapping' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
____________________ ERROR collecting tests/test_parser.py _____________________
ImportError while importing test module '/builddir/build/BUILD/rply-0.7.6/tests/test_parser.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
tests/test_parser.py:5: in <module>
    from rply import ParserGenerator, ParsingError, Token
rply/__init__.py:3: in <module>
    from rply.parsergenerator import ParserGenerator
rply/parsergenerator.py:12: in <module>
    from rply.grammar import Grammar
rply/grammar.py:2: in <module>
    from rply.utils import iteritems
rply/utils.py:2: in <module>
    from collections import MutableMapping
E   ImportError: cannot import name 'MutableMapping' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
________________ ERROR collecting tests/test_parsergenerator.py ________________
ImportError while importing test module '/builddir/build/BUILD/rply-0.7.6/tests/test_parsergenerator.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
tests/test_parsergenerator.py:5: in <module>
    from rply import ParserGenerator, Token
rply/__init__.py:3: in <module>
    from rply.parsergenerator import ParserGenerator
rply/parsergenerator.py:12: in <module>
    from rply.grammar import Grammar
rply/grammar.py:2: in <module>
    from rply.utils import iteritems
rply/utils.py:2: in <module>
    from collections import MutableMapping
E   ImportError: cannot import name 'MutableMapping' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
_____________________ ERROR collecting tests/test_utils.py _____________________
ImportError while importing test module '/builddir/build/BUILD/rply-0.7.6/tests/test_utils.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
tests/test_utils.py:5: in <module>
    from rply.utils import IdentityDict
rply/__init__.py:3: in <module>
    from rply.parsergenerator import ParserGenerator
rply/parsergenerator.py:12: in <module>
    from rply.grammar import Grammar
rply/grammar.py:2: in <module>
    from rply.utils import iteritems
rply/utils.py:2: in <module>
    from collections import MutableMapping
E   ImportError: cannot import name 'MutableMapping' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
___________________ ERROR collecting tests/test_warnings.py ____________________
ImportError while importing test module '/builddir/build/BUILD/rply-0.7.6/tests/test_warnings.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
tests/test_warnings.py:1: in <module>
    from rply import ParserGenerator
rply/__init__.py:3: in <module>
    from rply.parsergenerator import ParserGenerator
rply/parsergenerator.py:12: in <module>
    from rply.grammar import Grammar
rply/grammar.py:2: in <module>
    from rply.utils import iteritems
rply/utils.py:2: in <module>
    from collections import MutableMapping
E   ImportError: cannot import name 'MutableMapping' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
_________________ ERROR collecting tests/test_ztranslation.py __________________
ImportError while importing test module '/builddir/build/BUILD/rply-0.7.6/tests/test_ztranslation.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
tests/test_ztranslation.py:8: in <module>
    from rply import LexerGenerator, ParserGenerator, Token
rply/__init__.py:3: in <module>
    from rply.parsergenerator import ParserGenerator
rply/parsergenerator.py:12: in <module>
    from rply.grammar import Grammar
rply/grammar.py:2: in <module>
    from rply.utils import iteritems
rply/utils.py:2: in <module>
    from collections import MutableMapping
E   ImportError: cannot import name 'MutableMapping' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
=========================== short test summary info ============================
ERROR tests/test_both.py
ERROR tests/test_lexer.py
ERROR tests/test_parser.py
ERROR tests/test_parsergenerator.py
ERROR tests/test_utils.py
ERROR tests/test_warnings.py
ERROR tests/test_ztranslation.py
!!!!!!!!!!!!!!!!!!! Interrupted: 7 errors during collection !!!!!!!!!!!!!!!!!!!!
============================== 7 errors in 0.31s ===============================

bpo-37324: Remove deprecated aliases to Collections Abstract Base Classes
from the collections module.

https://docs.python.org/3.10/whatsnew/changelog.html#python-3-10-0-alpha-5

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01952444-python-rply/

For all our attempts to build python-rply with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-rply/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2021-02-09 16:07:21 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 2 Miro Hrončok 2021-06-04 20:13:52 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 3 Miro Hrončok 2021-06-07 22:58:35 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 4 Miro Hrončok 2021-06-08 11:32:28 UTC
*** Bug 1969120 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.