Bug 1926337 - python-troveclient fails to build with Python 3.10: AttributeError: module 'collections' has no attribute 'Iterable'
Summary: python-troveclient fails to build with Python 3.10: AttributeError: module 'c...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-troveclient
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Joel Capitao
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1969163 (view as bug list)
Depends On: 1914840 1969012 1969013 1969030 1969068 1969076 1969077 1969150
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-02-08 16:36 UTC by Miro Hrončok
Modified: 2021-06-21 06:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-17 16:58:26 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2021-02-08 16:36:53 UTC
python-troveclient fails to build with Python 3.10.0a5.

======================================================================
ERROR: test__pretty_paged (troveclient.compat.tests.test_common.CommandsBaseTest)
troveclient.compat.tests.test_common.CommandsBaseTest.test__pretty_paged
----------------------------------------------------------------------
testtools.testresult.real._StringException: Traceback (most recent call last):
  File "/builddir/build/BUILD/python-troveclient-5.1.1/troveclient/compat/tests/test_common.py", line 257, in test__pretty_paged
    class MockIterable(collections.Iterable):
AttributeError: module 'collections' has no attribute 'Iterable'


----------------------------------------------------------------------
Ran 388 tests in 2.317s

FAILED (errors=1)

bpo-37324: Remove deprecated aliases to Collections Abstract Base Classes
from the collections module.

https://docs.python.org/3.10/whatsnew/changelog.html#python-3-10-0-alpha-5

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01952523-python-troveclient/

For all our attempts to build python-troveclient with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-troveclient/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2021-02-09 16:07:35 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 2 Joel Capitao 2021-02-11 11:29:44 UTC
I proposed a patch upstream: https://review.opendev.org/c/openstack/python-troveclient/+/775121

Comment 3 Miro Hrončok 2021-06-04 20:15:46 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 4 Miro Hrončok 2021-06-07 23:00:08 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 5 Miro Hrončok 2021-06-08 11:35:12 UTC
*** Bug 1969163 has been marked as a duplicate of this bug. ***

Comment 6 Miro Hrončok 2021-06-15 20:25:04 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 7 Joel Capitao 2021-06-17 16:58:26 UTC
Fixed with https://koji.fedoraproject.org/koji/taskinfo?taskID=70312930


Note You need to log in before you can comment on or make changes to this bug.