Bug 1969076 - F35FailsToInstall: python3-oslo-serialization, python3-oslo-serialization-tests [NEEDINFO]
Summary: F35FailsToInstall: python3-oslo-serialization, python3-oslo-serialization-tests
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-oslo-serialization
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Joel Capitao
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1973121 (view as bug list)
Depends On: 1969077
Blocks: F35FailsToInstall PYTHON3.10 1926337 1968893 1968952 1969000 1969013 1969022 1969049 1969058 1969075 1969124 1969152 1969153
TreeView+ depends on / blocked
 
Reported: 2021-06-07 23:43 UTC by Miro Hrončok
Modified: 2021-06-17 10:27 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-17 09:47:47 UTC
Type: ---
mhroncok: needinfo? (apevec)


Attachments (Terms of Use)

Description Miro Hrončok 2021-06-07 23:43:08 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

Your package (python-oslo-serialization) Fails To Install in Fedora 35:

can't install python3-oslo-serialization:
  - nothing provides python(abi) = 3.9 needed by python3-oslo-serialization-4.1.0-1.fc35.noarch
  
can't install python3-oslo-serialization-tests:
  - nothing provides python(abi) = 3.9 needed by python3-oslo-serialization-tests-4.1.0-1.fc35.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-06-07 23:47:25 UTC
This bugzilla is likely a fallout from the Python 3.10 rebuild.

If your package (or some of the dependencies it has) failed to rebuild during the Python 3.10 rebuild, they now fail to install. To fix this, packages need to be rebuilt in Rawhide.

We will slowly triage the bugzillas, but we'd appreciate your help.

If you know this is blocked by an existing reported build failure or another package not yet rebuilt with Python 3.10, please mark it as such by using the "Depends On"/"Blocks" bugzilla fields. That will help us determine what failures to prioritize.

Thank you and sorry for the inconvenience. Let me know if you need any help.

Comment 2 Miro Hrončok 2021-06-15 20:52:06 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 3 Joel Capitao 2021-06-16 07:24:42 UTC
I built eventlet and deps locally in order to catch error earlier for all openstack-sig packages.
oslo-serialization needs a patch which I prepared and submitted in [2] but haven't created PR yet 
in order to save CI resources. I'll sumbit it once eventlet and deps (i.e oslo-utils) fixed and 
available in rawhide repo.

[1] https://github.com/eventlet/eventlet/pull/715
[2] https://src.fedoraproject.org/fork/jcapitao/rpms/python-oslo-serialization/c/cb6d90b3a53f2b4b9c36510fe91ea74b6658dd65?branch=rawhide

Comment 4 Joel Capitao 2021-06-17 09:47:47 UTC
Fixed with https://koji.fedoraproject.org/koji/taskinfo?taskID=70284935

Comment 5 Miro Hrončok 2021-06-17 10:27:59 UTC
*** Bug 1973121 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.