Bug 192657 - toolbar rendering glitches
toolbar rendering glitches
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-bridge (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks: FC6Blocker SCIM
  Show dependency treegraph
 
Reported: 2006-05-22 12:55 EDT by Warren Togami
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-23 03:18:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2006-05-22 12:55:34 EDT
Visual rendering glitches of the language bar can be observed in certain
circumstances when using scim-bridge as your immodule.

Reproduce Procedure:
1. Run two GTK+ applications.
2. Activate the language bar in both applications.
3. ALT-TAB to switch between the two applications.
4. Dismiss the language bar in both applications.

All subsequent ALT-TAB switching between the two applications you can observe
either:
1. A language bar that is rendered onto the screen, but not functional because
it is actually dismissed.
2. A momentary visual glitch of failed rendering where the language bar would be
while you switch between applications.
3. Sometimes clicking within applications like xchat causes rendering glitches
where the dismissed language bar would be.

These are only visual glitches.  There does not seem to be any functional or
interface problem caused by this.
Comment 1 Jens Petersen 2006-06-06 00:10:03 EDT
Warren, can you reproduce with scim-bridge-0.1.12?
I don't seem able to.
Comment 2 Jens Petersen 2006-06-23 03:18:52 EDT
------- Additional Comments From wtogami@redhat.com  2006-06-12 10:10 EST -------
Seems good now, great work Dairiki.

Note You need to log in before you can comment on or make changes to this bug.