Bug 192676 - multilib -devel conflicts for gmp
multilib -devel conflicts for gmp
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gmp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
: Reopened
: 205209 (view as bug list)
Depends On:
Blocks: multilibdevel
  Show dependency treegraph
 
Reported: 2006-05-22 13:54 EDT by Jeremy Katz
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.1.4-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 10:46:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2006-05-22 13:54:31 EDT
The package contains conflicting -devel packages for multilib arches.

gmp-devel-4.1.4-6.2.1.i386.rpm
warning: gmp-devel-4.1.4-6.2.1.i386.rpm: Header V3 DSA signature: NOKEY, key ID
4f2a6fd2
Preparing...                ##################################################
        file /usr/include/gmp-mparam.h from install of gmp-devel-4.1.4-6.2.1 con
flicts with file from package gmp-devel-4.1.4-6.2.1
        file /usr/include/gmp.h from install of gmp-devel-4.1.4-6.2.1 conflicts
with file from package gmp-devel-4.1.4-6.2.1
Comment 1 Laurent Rineau 2006-07-20 05:52:07 EDT
IMO, this is not a bug: you cannot expect to install -devel sub-packages from 
different arch repositories.

If you want to be able to compile i386 applications on your machine, you'll 
have to setup a chrooted installation of a pure i386 Fedora.

Please re-open the bug if it happens that i have missed something.
Comment 2 Jeremy Katz 2006-07-20 09:11:20 EDT
You're missing the point entirely.  We have shipped an x86 runtime on x86_64 for
a while, we're now expanding that to include development support for FC6.  Thus,
this needs to be fixed (you'll note that gmp-devel.i386 is included in the
x86_64 tree now)
Comment 3 Laurent Rineau 2006-07-20 09:46:23 EDT
Ok. That bug is then a bug common to a lot of -devel packages, IMO.
Comment 4 Jeremy Katz 2006-10-02 17:51:16 EDT
*** Bug 205209 has been marked as a duplicate of this bug. ***
Comment 5 Laurent Rineau 2006-12-01 09:46:31 EST
(I am doing bug triage about gmp.)

As far as I know, this bug is know fixed, since gmp-4.1.4-9. Can anybody using 
a multiarch platform confirm?
Comment 6 Jeremy Katz 2006-12-01 10:46:29 EST
Looks fixed to me; thanks for the triaging!

Note You need to log in before you can comment on or make changes to this bug.