Bug 192708 - multilib -devel conflicts for libgssapi
Summary: multilib -devel conflicts for libgssapi
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgssapi (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
: 205220 (view as bug list)
Depends On:
Blocks: multilibdevel
TreeView+ depends on / blocked
 
Reported: 2006-05-22 18:09 UTC by Jeremy Katz
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 21:11:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2006-05-22 18:09:08 UTC
The package contains conflicting -devel packages for multilib arches.

libgssapi-devel-0.7-2.1.i386.rpm
warning: libgssapi-devel-0.7-2.1.i386.rpm: Header V3 DSA signature: NOKEY, key I
D 4f2a6fd2
Preparing...                ##################################################
        file /usr/include/gssglue/gssapi/gssapi.h from install of libgssapi-deve
l-0.7-2.1 conflicts with file from package libgssapi-devel-0.7-2.1

Comment 1 Steve Dickson 2006-07-25 20:14:03 UTC
I believe this is fixed in that latest Rawhide release, Please
reopen if this is not the case... 

Comment 2 Jeremy Katz 2006-07-25 20:18:25 UTC
Absolutely no change.

python ~/multilib-cmp.py x86_64/libgssapi-devel-0.9-2.1.x86_64.rpm
i386/libgssapi-devel-0.9-2.1.i386.rpm 
File conflict for /usr/include/gssglue/gssapi/gssapi.h in libgssapi-devel-0.9-2.1

Comment 3 Steve Dickson 2006-07-25 20:39:26 UTC
ah... so this problem happens when both i686 and x86_64 packages
are installed on the same machine... Yeah I guess there would be a problem
with that.. any suggestion on how to deal with that? How do other libs
deal with this situation?

Comment 4 Jeremy Katz 2006-07-25 20:41:45 UTC
I sent a lengthy mail describing the problem as well as solution paths -- start
of the thread is at
  https://www.redhat.com/archives/fedora-maintainers/2006-May/msg00014.html

Comment 5 Jeremy Katz 2006-10-02 21:54:07 UTC
*** Bug 205220 has been marked as a duplicate of this bug. ***

Comment 6 Steve Dickson 2007-03-09 13:54:30 UTC
Fixed in libgssapi-0.10-2.fc7


Note You need to log in before you can comment on or make changes to this bug.