Bug 205220 - File conflicts
File conflicts
Status: CLOSED DUPLICATE of bug 192708
Product: Fedora
Classification: Fedora
Component: libgssapi (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks: multilibdevel
  Show dependency treegraph
 
Reported: 2006-09-05 10:25 EDT by Bill Nottingham
Modified: 2014-03-16 23:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 17:53:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-09-05 10:25:07 EDT
Description of problem:
        file /usr/include/gssglue/gssapi/gssapi.h from install of
libgssapi-devel-0.10-1 conflicts with file from package libgssapi-devel-0.10-1
Comment 1 Steve Dickson 2006-09-05 11:05:08 EDT
How there be an file confliction with in itsself?
Comment 2 Bill Nottingham 2006-09-05 11:06:47 EDT
The headers conflict on i386 and x86_64.
Comment 3 Steve Dickson 2006-09-05 11:24:51 EDT
So both version (i386 and x86_64) have to be able to 
live on the same machine? If that's the case, there
will probably be problems with nfs-utils-lib as well...
Comment 4 Bill Nottingham 2006-09-05 11:29:33 EDT
Correct; the idea is that you can develop for both arches on x86_64. Why would
the -lib packge conflict - the libraries should be under different paths?
Comment 5 Steve Dickson 2006-09-05 11:50:25 EDT
yes... the gssglue/gssapi/gssapi.h is where the
package config file (i.e. libgssapi.pc) defines
where the libgssapi header file live...

So as not to reinvent the wheel... How is this
handled in other packages and is there some
type of naming convention that should be used
to decipher between x86 and x86_64 paths?
Comment 6 Bill Nottingham 2006-09-05 11:57:46 EDT
Generally, pkg-config files go in $(libdir)/pkgconfig.

Arch-specific header files could be in /usr/include/<name>/<arch>, or in
$(libdir)/<name>/include (glibc does the former, glib the latter).
Comment 7 Jeremy Katz 2006-10-02 17:53:53 EDT

*** This bug has been marked as a duplicate of 192708 ***

Note You need to log in before you can comment on or make changes to this bug.