Bug 19272 - Installer crashes at post-installation with signal 11
Summary: Installer crashes at post-installation with signal 11
Status: CLOSED DUPLICATE of bug 17991
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-17 17:09 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-27 17:31:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-17 17:09:14 UTC
The installer receives a signal 11 at post-installation. The machine is a IBM Thinkpad T20 with 256MB and 20 GB drive, the graphics adapter is 
a S3 Savage IX w/MV.

The installation method is FTP, I first boot with the pcmcia.img giving linux mem=256M at the prompt. I tried with the updates, however it 
always fails with the updates while trying to access the glibc package (the access path is wrong, may be a bug in the anaconda scripts).

Anyway, everything is going fine until I reach the post-installation step, it the crashes and I have no way to look at the log since the system is 
never installed. This system is already running Windows 98, the Windows partition was set to 4 GB using Partition Magic and the remaining 
disk space is available for my installation.

I selected the MBR method as startup method.

I selected the generic S3 Savage graphics driver for my adapter.

I also tried the HTTP method with the same results (even with the updates disk).

What is going wrong?

Comment 1 Need Real Name 2000-10-20 18:57:09 UTC
I tested without installing any X-Window software. It doesn't make any difference. So, it is not related to the graphics driver setup at post-installation.

Comment 2 Need Real Name 2000-10-26 17:14:00 UTC
In case you are asking yourself, yes, this system has run Linux. In fact, as another test, I just installed Mandrake 7.0 yesterday. However, my intention 
is still to install the RedHat distribution. So, don't close the problem and don't be offuscated!

Comment 3 Michael Fulbright 2000-10-27 21:47:16 UTC
Please try a text mode install by typing 'linux text' at the intaller boot
prompt .

Then towards the end of the install (before the point where it crashes) switch
to VC3 by hitting CNTL-ALT-F3.  Watch that screen and when it seems you machine
has crashed  try to note the last few lines of text. This will help us
understand where it is dying.

Comment 4 Need Real Name 2000-10-30 16:18:15 UTC
The screen is as follow:

----------------------------------
(some other messages before ...)

* getting ready to spawn shell now
* probing buses
* finished bus probing
* found suggestion of usb-uhci
* found nothing
* going to insmod raid0.o (path is NULL)
* going to insmod raid1.o (path is NULL)
* going to insmod raid5.o (path is NULL)
* going to insmod fat.o (path is NULL)
* going to insmod vfat.o (path is NULL)
* going to insmod ext3.o (path is NULL)
* looking for USB mouse...
* no IDE floppy devices found
* making cd-rom links
---------------------------------------

That's it!

Comment 5 Michael Fulbright 2000-11-17 16:41:20 UTC
Could you try installing using mem=64M instead of 256M just out of curiosity?


Comment 6 Need Real Name 2000-11-22 16:14:58 UTC
Ok, I did it. However, I also installed from the CDs instead from the network. And it completed successfully using also mem=64M.

Is it possible to get some kind of explanation on this problem? I would like what was going on.

Comment 7 Need Real Name 2000-11-22 16:17:59 UTC
BTW, if someone is reading this in the future for installation on the Thinkpad T20, the XF86_SVGA server is not working with the S3 Savage, there is 
some web pages on the IBM Thinkpad T20 and Linux, all mention where to pick a working server. I installed it and it is working fine. As well as the 
Linmodem driver. All with RedHat 7.0. (End of commercial, thanks!)

Comment 8 Michael Fulbright 2000-12-27 17:26:27 UTC
Assigning to developer to look into X problems in last comment.

Comment 9 Bill Nottingham 2000-12-27 17:31:52 UTC
that's not a kudzu problem, that's an X problem.

Comment 10 Mike A. Harris 2001-02-28 06:29:10 UTC

*** This bug has been marked as a duplicate of 17991 ***


Note You need to log in before you can comment on or make changes to this bug.