Bug 192747 - multilib -devel conflicts for python
multilib -devel conflicts for python
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
Depends On:
Blocks: 139911 multilibdevel
  Show dependency treegraph
 
Reported: 2006-05-22 14:29 EDT by Jeremy Katz
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-22 13:33:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2006-05-22 14:29:48 EDT
The package contains conflicting -devel packages for multilib arches.

python-devel-2.4.3-3.i386.rpm
Preparing...                ##################################################
        file /usr/include/python2.4/pyconfig.h from install of python-devel-2.4.
3-3 conflicts with file from package python-devel-2.4.3-3
Comment 1 Mihai Ibanescu 2006-06-08 10:38:24 EDT
Ugh. looking at python-devel-2.4.2-3.2.1:

-/* #undef HAVE_LARGEFILE_SUPPORT */
+#define HAVE_LARGEFILE_SUPPORT 1
-#define SIZEOF_LONG 8
+#define SIZEOF_LONG 4
-#define SIZEOF_PTHREAD_T 8
+#define SIZEOF_PTHREAD_T 4
-#define SIZEOF_TIME_T 8
+#define SIZEOF_TIME_T 4
-#define SIZEOF_VOID_P 8
+#define SIZEOF_VOID_P 4
-#define VA_LIST_IS_ARRAY 1
+/* #undef VA_LIST_IS_ARRAY */

Seems to be related to bug 116826 too
Comment 2 Mihai Ibanescu 2006-06-08 10:42:11 EDT
And bug 139911 has similar issues. I have to find the thread on python-dev where
I asked for help fixing this problem.
Comment 3 Jeremy Katz 2006-06-22 13:33:03 EDT
This is fixed now

Note You need to log in before you can comment on or make changes to this bug.