Bug 192761 - SATA Errors prevent installation on MSI K7N2 Nforce 2 with SATA drive
SATA Errors prevent installation on MSI K7N2 Nforce 2 with SATA drive
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-22 15:41 EDT by Jeremy Parsons
Modified: 2015-01-04 17:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 18:19:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Parsons 2006-05-22 15:41:18 EDT
Description of problem:
BIOS and Anaconda properly discover and partition the single hard drive (Maxtor
6V200E0 SATA 200GB) but then fail after Exception caused by SATA errors during
format. Tried kernel options but did not seem to change anything:
acpi=off ide=nodma nodmraid noapic

Version-Release number of selected component (if applicable):
i386

How reproducible:
Every time

Steps to Reproduce:
1. Boot from FC5 installation DVD
2. In anaconda pick auto or manual disk partitioning
3. 
  
Actual results:
Exception during mkfs
Error: Input/output error during write on /dev/sda

Expected results:
Format filesystems properly

Additional info:
Other distros have similar problem however Damn Small Linux 2.3 (DSL 2.3)
installed fine. DSL uses a 2.4 Kernel so I guess its another Kernel 2.6 problem
? I have tried to install FC5 on four very different computers so far and failed
on all but one ! The hard disk is brand new and seems to slow DSL significantly
when the formatting is taking place even on a fast Athlon computer: screen
refresshes become slower etc.
Comment 1 Jeremy Parsons 2006-05-24 19:46:20 EDT
The error messages that look most relavent are:
<4>ATA: abnormal status 0xD0 on port 0x977, Scsi parity erro
<3> ata2: command 0x35 timeout stat 0xd0 host)stat 0x21

The good news is that I discovered that by turning the computer on and off
instead of just resetting, and then adding the "nodma" kernel option to the FC5
installation command line ("linux nodma") allowed me to install FC5. After a few
more boots and rescues I had a "nodma" kernel option in my grub menu.lst and I
was able to boot far enough to run "yum update" (on 24th May 2006) which pulled
in the new kernel which supports the specific SATA drivers properly and gives me
65 MB/s on hdparm timed reads. (Kernel 2.4 in DSL without DMA was only able to
get 10 MB/s). It seems to be working so far but reset button still needs to be
followed by on/off  to get a complete boot ...
Comment 2 Dave Jones 2006-10-16 20:54:15 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 3 Dave Jones 2006-11-24 18:19:31 EST
This bug has been mass-closed along with all other bugs that
have been in NEEDINFO state for several months.

Due to the large volume of inactive bugs in bugzilla, this
is the only method we have of cleaning out stale bug reports
where the reporter has disappeared.

If you can reproduce this bug after installing all the
current updates, please reopen this bug.

If you are not the reporter, you can add a comment requesting
it be reopened, and someone will get to it asap.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.